HPQLB(4) BSD Kernel Interfaces Manual HPQLB(4)NAME
hpqlb -- HP Quick Launch Buttons
hpqlb* at acpi?
Many HP notebook computers come with hotkeys. The hpqlb driver provides support for all hotkeys generating keycodes.
The following hotkeys which do not generate keycodes are:
o Display Switch
o Brightness Up
o Brightness Down
SEE ALSO acpi(4)HISTORY
The hpqlb driver appeared in NetBSD 5.0.
This driver was written for NetBSD by Christoph Egger.
The hpqlb driver conflicts with wmihp(4).
BSD April 8, 2010 BSD
Check Out this Related Man Page
HPACEL(4) BSD Kernel Interfaces Manual HPACEL(4)NAME
hpacel -- HP 3D DriveGuard accelerometer
hpacel* at acpi?
The hpacel device driver supports accelerometers that are commonly available in Hewlett-Packard laptops. The supported chip is LIS3LV02DL
from STMicroelectronics, although other chips from the same family, such as LIS3LV02DQ, may also work, provided that the vendor has imple-
mented suitable ACPI access methods.
The hpacel driver reports the acceleration readings of the X-, Y-, and Z-axis via the envsys(4) API and the envstat(8) command.
SEE ALSO acpi(4), aps(4), hpqlb(4), wmihp(4)
STMicroelectronics, LIS3LV02DL: 3-Axis - +-2g/+-6g digital output low voltage linear accelerometer. AN2381 Application Note, Revision 1,
http://www.st.com/stonline/products/literature/anp/12441.pdf, June, 2006.
The hpacel device driver appeared in NetBSD 6.0.
Jukka Ruohonen <email@example.com>
The used accelerometer chip is capable of generating wake-up, direction detection, and free-fall interrupts. In the ideal situation these
could be used to evoke possible emergency action. However, the hpacel driver only reports the readings from the accelerometer via
BSD September 7, 2011 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)