HIL(4) BSD Kernel Interfaces Manual HIL(4)NAME
hil -- introduction to HP-HIL support
hil* at intio?
hilkbd* at hil?
hilms* at hil?
hilid* at hil?
The hil interface provides access to the ``Human Interface Loop'' controller found on many HP workstations.
It provides generic HIL management and interfaces for child devices, such as keyboards, button boxes, mice, graphics tablet, and ID modules.
NetBSD provides support for the following devices:
hilid(4) HIL ID module device
hilkbd(4) HIL keyboard device
hilms(4) HIL mouse and graphics tablet device
SEE ALSO intro(4)BSD February 9, 2011 BSD
Check Out this Related Man Page
hilkbd(7) Miscellaneous Information Manual hilkbd(7)NAME
hilkbd - HP-HIL mapped keyboard driver
HP-HIL, the Hewlett-Packard Human Interface Link, is the Hewlett-Packard standard for interfacing a personal computer, terminal, or work-
station to its input devices. supplies input from all mapped keyboards on a specified HP-HIL link.
returns mapped keycodes, not ASCII characters. "Raw" keycodes are the individual key downstrokes and upstrokes, and are different for each
type of keyboard. maps the raw input into the keycodes and protocol expected by the HP-UX, Pascal Workstation, and BASIC/UX operating sys-
tems. The driver can usurp a keyboard from by changing it from mapped mode to raw mode.
gives exclusive access to the keyboard. If there is an ITE (internal terminal emulator) associated with the keyboard, the ITE loses input
from the keyboard until the keyboard device is closed. Any previous queued input for the keyboard device is flushed from the input queue.
returns control of the keyboard to the ITE, if present. Any unread input is discarded at that time.
returns data from the keyboard in time-stamped packets:
time_stamp, when repacked into an integer data type of four or more bytes, specifies the time since an arbitrary point in the past (for
example, system start-up time). This point does not change between packets, but time during a power failure may or may not be counted.
The time is in units of tens of milliseconds.
The status byte encodes the state of the keyboard and keys:
0x8X shift and control
0x9X control only
0xAX shift only
0xBX no shift or control
The data byte contains the actual keystroke.
If the file status flag O_NDELAY is set, returns instead of blocking, when no data is available. The system call on an HP-HIL keyboard is
considered "slow"; that is, it can be interrupted by caught signals (see signal(2)).
is not supported by
can be used to poll for input to read from devices. for write or for exceptional conditions always returns a false indication in the bit
is used to perform special operations on the device. system calls have the form:
The following request codes are defined in
Read the configuration code.
This request returns a one-byte configuration code in the variable to which arg points. This contains a field, defined by
which specifies the keyboard identification code. The possible values of this field are defined in the header file, and
this identification code affects interpretation of the language code. All other fields in the configuration code are cur-
Read the language code.
This request returns a one-byte language code, as read from the keyboard, in the variable to which arg points. If there is
more than one keyboard, the language is taken from the first keyboard on the link. Interpretation of the language code is
affected by the keyboard identification field within the configuration code.
Read the keyboard status register.
This request returns a one-byte value containing bit flags specifying the state of the shift and control keys in the vari-
able to which arg points:
KBD_STAT_LEFTSHIFT The left shift key is up
KBD_STAT_RIGHTSHIFT The right shift key is up
KBD_STAT_SHIFT Both shift keys are up
KBD_STAT_CTRL The control key is up
Other bits are undefined.
Set the keyboard auto-repeat rate.
The one-byte value to which arg points is the negative of the repeat period, in tens of milliseconds. The repeat rate is
the reciprocal of the repeat period. A parameter of zero disables auto-repeat.
Set the keyboard auto-repeat delay.
The one-byte value to which arg points is the negative of the repeat delay, in tens of milliseconds.
Cause an audible beep.
The one-byte value to which arg points specifies the volume of the beep, within the range through Implementations with fewer
than discrete levels of volume will scale the parameter into the smaller range.
An invalid parameter was detected by
A signal was caught during a
No keyboard is present on the HP-HIL
link specified by the minor number.
An attempt was made to use
The device is already open.
was developed by the Hewlett-Packard Company.
SEE ALSO mknod(1M), select(2), signal(2), hil(7), termio(7).