FUJBP(4) BSD Kernel Interfaces Manual FUJBP(4)NAME
fujbp, fujhk -- Fujitsu Brightness, Pointer, and Hotkeys
fujbp* at acpi?
fujhk* at acpi?
Some Fujitsu laptops come with vendor-specific ACPI devices to manage the laptop hotkeys (such as the 'Eco' button), and to control various
built-in components (such as the display, the touchpad, and the speakers). The fujbp and fujhk drivers provide support, through these ACPI
devices, for hotkeys, backlight on/off switch, brightness level control, and pointer on/off switch.
The following sysctl(8) read/write variables are provided (when hardware support is available):
hw.acpi.fujbp0.brightness Brightness level (integer).
hw.acpi.fujbp0.pointer Pointer switch state (boolean).
hw.acpi.fujhk0.backlight Backlight switch state (boolean).
Please note, however, that future versions of the drivers may remove these sysctl(8) variables without prior notice.
SEE ALSO acpi(4), acpivga(4), sysctl(8), pmf(9), sysmon_pswitch(9)HISTORY
The fujbp and fujhk drivers appeared in NetBSD 6.0.
Gregoire Sutre <gsutre@NetBSD.org>
Brightness level and backlight switch state should be controlled via wsconsctl(8) instead of sysctl(8).
The sysctl(8) variable hw.acpi.fujbp0.pointer should be replaced by a platform-independent userland control.
BSD February 20, 2011 BSD
Check Out this Related Man Page
ACPIVGA(4) BSD Kernel Interfaces Manual ACPIVGA(4)NAME
acpivga -- ACPI Display Adapter and Output Devices
acpivga* at acpi?
acpiout* at acpivga?
The acpivga driver provides generic support for brightness control and output switching, through ACPI video extensions. The ACPI specifica-
tion requires that systems containing a built-in display adapter implement these extensions in their ACPI BIOS.
The driver handles brightness hotkeys and display switch hotkeys. In addition, the following sysctl(8) read/write variables are provided
(when hardware support is available):
BIOS output switching policy. This boolean variable controls the behavior of the BIOS when a display switch hotkey is pressed.
1 the BIOS should automatically switch outputs, with no interaction from acpivga.
0 the BIOS should only notify acpivga of the desired output state changes.
Brightness level. This integer variable typically ranges from 0 to 100, but any integer value is accepted (the driver uses the clos-
est brightness level supported by the device).
Please note, however, that future versions of acpivga may remove these sysctl(8) variables without prior notice.
SEE ALSO acpi(4), vga(4), sysctl(8)
Microsoft Corporation, Mobile System Displays and Windows, Version 1.2c, http://www.microsoft.com/whdc/archive/mobiledisplay.mspx, December
The acpivga driver appeared in NetBSD 6.0.
Gregoire Sutre <gsutre@NetBSD.org>
The acpivga driver only supports PCI/PCI-X/PCI-E display adapters.
Many ACPI BIOSes implement only part of the ACPI video extensions. In particular, display output switching via these extensions often does
not work. For this reason, acpivga enables hw.acpi.acpivga0.bios_switch by default. If the display switch hotkey does not work with this
default setting, try setting hw.acpi.acpivga0.bios_switch to 0.
Brightness level should be controlled via wsconsctl(8) instead of sysctl(8).
BSD October 28, 2010 BSD
I want to install NetBSD on the Compaq LTE 5000. ("Of course it runs NetBSD!!") But the laptop does NOT have a CD-ROM drive.
How can I solve??
Thanks for any reply! :)
PS: I hope i'm posting in the right item... (2 Replies)
I have been trying to access bios info regarding temperatures under my Slackware 13.37 OS.
I first looked at /proc/acpi/processor/CPU0/throttling where I found my active state to be T0 and my state count is 16. My understanding is that T0 is 100% throttling of either the CPU fan or the processor... (5 Replies)
I have two DELL OPTIPLEX 330 x64 PCs with dual core (2.2ghz x2), 2gigs ram. First one is dual boot with Ubuntu on top of Windows XP pro 86. Second one is stand alone Ubuntu.
The CRT monitors on both PCs periodically fade as if they are going into standby mode. But they don't go completely... (12 Replies)