Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

fss(4) [netbsd man page]

FSS(4)							   BSD Kernel Interfaces Manual 						    FSS(4)

NAME
fss -- file system snapshot device SYNOPSIS
pseudo-device fss 4 DESCRIPTION
The fss driver provides a read-only interface to the snapshot of a currently mounted file system. Reading from a fss device gives the view of the file system when the snapshot was taken. It can be configured via ioctl(2). IOCTLS
The ioctl(2) command codes below are defined in <sys/dev/fssvar.h>. The (third) argument to ioctl(2) should be a pointer to the type indicated. FSSIOCSET(struct fss_set) Configures a fss device. struct fss_set { char *fss_mount; char *fss_bstore; blksize_t fss_csize; int fss_flags; }; The struct element fss_mount is the mount point of the file system. The struct element fss_bstore is either a regular file or a raw disk device where data overwritten on the file system will be saved. The struct element fss_csize is the preferred size of this data. The struct element fss_flags is the initial set of flags. FSSIOCGET(struct fss_get) Gets the status of a fss device. struct fss_get { char fsg_mount[MNAMELEN]; struct timeval fsg_time; blksize_t fsg_csize; blkcnt_t fsg_mount_size; blkcnt_t fsg_bs_size; }; The struct element fsg_mount is the mount point of the file system. The struct element fsg_time is the time this snapshot was taken. The struct element fsg_csize is the current size of data clusters. The struct element fsg_mount_size is the number of clusters of the file system. The struct element fsg_bs_size is the number of clusters written to the backing store. FSSIOCCLR Unconfigures a fss device. FSSIOFSET(int) Sets the flags of a fss device. Possible flags are: FSS_UNCONFIG_ON_CLOSE Unconfigure the fss device on the last close. FSS_UNLINK_ON_CREATE Unlink the backing file before the fss device is created. FSSIOFGET(int) Gets the flags of a fss device. KERNEL THREADS
For each active snapshot device there is a kernel thread that handles the backing store. This thread is named fssN where N is the device minor number. FILES
/dev/rfss? /dev/fss? SEE ALSO
fssconfig(8), mount(8), umount(8) HISTORY
The fss device appeared in NetBSD 2.0. BSD
February 24, 2011 BSD

Check Out this Related Man Page

STRUCT 
DEVICE_DRIVER(9) Device drivers infrastructure STRUCT DEVICE_DRIVER(9) NAME
struct_device_driver - The basic device driver structure SYNOPSIS
struct device_driver { const char * name; struct bus_type * bus; struct module * owner; const char * mod_name; bool suppress_bind_attrs; const struct of_device_id * of_match_table; const struct acpi_device_id * acpi_match_table; int (* probe) (struct device *dev); int (* remove) (struct device *dev); void (* shutdown) (struct device *dev); int (* suspend) (struct device *dev, pm_message_t state); int (* resume) (struct device *dev); const struct attribute_group ** groups; const struct dev_pm_ops * pm; struct driver_private * p; }; MEMBERS
name Name of the device driver. bus The bus which the device of this driver belongs to. owner The module owner. mod_name Used for built-in modules. suppress_bind_attrs Disables bind/unbind via sysfs. of_match_table The open firmware table. acpi_match_table The ACPI match table. probe Called to query the existence of a specific device, whether this driver can work with it, and bind the driver to a specific device. remove Called when the device is removed from the system to unbind a device from this driver. shutdown Called at shut-down time to quiesce the device. suspend Called to put the device to sleep mode. Usually to a low power state. resume Called to bring a device from sleep mode. groups Default attributes that get created by the driver core automatically. pm Power management operations of the device which matched this driver. p Driver core's private data, no one other than the driver core can touch this. DESCRIPTION
The device driver-model tracks all of the drivers known to the system. The main reason for this tracking is to enable the driver core to match up drivers with new devices. Once drivers are known objects within the system, however, a number of other things become possible. Device drivers can export information and configuration variables that are independent of any specific device. COPYRIGHT
Kernel Hackers Manual 3.10 June 2014 STRUCT DEVICE_DRIVER(9)
Man Page