BTKBD(4) BSD Kernel Interfaces Manual BTKBD(4)NAME
btkbd -- Bluetooth keyboard support
btkbd* at bthidev? reportid ?
wskbd* at btkbd? console ?
The btkbd driver provides support for Bluetooth wireless keyboards.
Bluetooth keyboards are configured using the btdevctl(8) program, and provide system access through the wscons(4) driver.
SEE ALSO bluetooth(4), bthidev(4), wskbd(4), btdevctl(8)HISTORY
The btkbd driver appeared in NetBSD 4.0 and was written by Iain Hibbert under the sponsorship of Itronix, Inc.
Due to the configuration and connection requirements, Bluetooth keyboards cannot be used until NetBSD is fully booted.
Bluetooth keyboards cannot be the NetBSD system console.
BSD May 16, 2009 BSD
Check Out this Related Man Page
BTHIDEV(4) BSD Kernel Interfaces Manual BTHIDEV(4)NAME
bthidev -- Bluetooth Human Interface Device support
bthidev* at bthub?
btkbd* at bthidev? reportid ?
btms* at bthidev? reportid ?
The bthidev driver handles all Bluetooth Human Interface Devices. Each HID device can have several components, e.g., a keyboard and a mouse.
These components use different report identifiers to distinguish which component data is coming from. The bthidev driver may have several
children attached that handle particular components and dispatches data to them based on the report id.
Normally, Bluetooth HIDs will be attached using the btdevctl(8) program. The following properties are used by the bthidev driver during
local-bdaddr Local device address.
remote-bdaddr Remote device address.
service-name The bthidev driver matches the 'HID' service.
control-psm This, if set, will indicate the PSM to use for the Control channel. If not set, L2CAP_PSM_HID_CNTL will be used.
interrupt-psm This, if set, will indicate the PSM to use for the Interrupt channel. If not set, L2CAP_PSM_HID_INTR will be used.
descriptor This required binary blob is the HID descriptor containing information about reports the device will produce, and obtained
reconnect If this boolean value is set, and is true, then the bthidev driver will initiate reconnections to the remote device when no
connection is present.
link-mode This optional string represents the link mode of the baseband link, and may be one of 'auth', 'encrypt', or 'secure'.
When the bthidev driver has configured its children, it will initiate a connection to the remote device. If this fails and the reconnect
flag is not set, it will then wait for the device to initiate the connection.
SEE ALSO bluetooth(4), bthub(4), btkbd(4), btms(4), btdevctl(8)HISTORY
The bthidev driver was written by Iain Hibbert under the sponsorship of Itronix, Inc. and first appeared in NetBSD 4.0.
BSD April 10, 2007 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)