AUBTFWL(4) BSD Kernel Interfaces Manual AUBTFWL(4)NAME
aubtfwl -- Atheros AR3011 Firmware Loader
SYNOPSIS
aubtfwl* at uhub?
DESCRIPTION
The aubtfwl driver manages automatic loading of firmware on the Atheros AR3011 Bluetooth chipset. The firmware file ath3k-1.fw should be
obtained and placed in a ubt/ directory in the search path of the firmload(9) kernel subsystem. Upon attachment, the aubtfwl driver will
load this firmware file and the device will detach and reattach as a generic Bluetooth device using the ubt(4) driver.
The firmware file can be obtained from the Linux firmware git repository at
http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git.
FILES
ath3k-1.fw
SEE ALSO bluetooth(4), ubt(4), uhub(4), firmload(9)BSD February 14, 2012 BSD
Check Out this Related Man Page
FIRMLOAD(9) BSD Kernel Developer's Manual FIRMLOAD(9)NAME
firmload -- Firmware loader API for device drivers
SYNOPSIS
#include <dev/firmload.h>
int
firmware_open(const char *drvname, const char *imgname, firmware_handle_t *fhp);
int
firmware_close(firmware_handle_t fh);
off_t
firmware_get_size(firmware_handle_t fh);
int
firmware_read(firmware_handle_t fh, off_t offset, void *buf, size_t size);
void *
firmware_malloc(size_t size);
void
firmware_free(void *buf, size_t size);
DESCRIPTION
firmload provides a simple and convenient API for device drivers to load firmware images from files residing in the file system that are nec-
essary for the devices that they control. Firmware images reside in sub-directories, one for each driver, of a series of colon-separated
path prefixes specified by the sysctl variable hw.firmware.path.
FUNCTIONS
The following functions are provided by the firmload API:
firmware_open(drvname, imgname, fhp)
Open then firmware image imgname for the driver drvname. The path to the firmware image file is constructed by appending the string
``/drvname/imgname'' to each configured path prefix until opening the firmware image file succeeds. Upon success, firmware_open()
returns 0 and stores a firmware image handle in the location pointed to by fhp. Otherwise, an error code is returned to indicate the
reason for failure.
firmware_close(fh)
Close the firmware image file associated with the firmware handle fh. Returns 0 upon success or an error code to indicate the reason
for failure.
firmware_get_size(fh)
Returns the size of the image file associated with the firmware handle fh.
firmware_read(fh, offset, buf, size)
Reads from the image file associated with the firmware handle fh beginning at offset offset for length size. The firmware image data
is placed into the buffer specified by buf. Returns 0 upon success or an error code to indicate the reason for failure.
firmware_malloc(size)
Allocates a region of wired kernel memory of size size. Note: firmware_malloc() may block.
firmware_free(buf, size)
Frees a region of memory previously allocated by firmware_malloc().
SEE ALSO autoconf(9), malloc(9), vnsubr(9)HISTORY
The firmload framework first appeared in NetBSD 4.0.
AUTHORS
Jason Thorpe <thorpej@NetBSD.org>
BSD January 17, 2006 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)