Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

atalk(4) [netbsd man page]

ATALK(4)						   BSD Kernel Interfaces Manual 						  ATALK(4)

NAME
atalk -- AppleTalk Protocol Family SYNOPSIS
#include <sys/types.h> #include <netatalk/at.h> DESCRIPTION
The AppleTalk Protocol Family provides presentation layer support for the AppleTalk Datagram Delivery Protocol (DDP), using the SOCK_DGRAM socket type. In addition, access to in-kernel AppleTalk routing tables and network interface configurations is provided. The AppleTalk Protocol Suite provides support for five kinds of physical media: LocalTalk (230kbps wire-or'd serial), Ethernet, FDDI, Token Ring, and asynchronous serial connections (using either AppleTalk Remote Access (ARA) or PPP ). Currently, NetBSD's AppleTalk implementation supports Ethernet, FDDI, and Token Ring. AppleTalk packets are encapsulated on the Ethernet using the EtherTalk Link Access Protocol (ELAP). Local network address resolution is han- dled using the AppleTalk Address Resolution Protocol (AARP). Neither of these protocols is exposed to user-mode applications. ADDRESSING
AppleTalk addresses are three byte quantities, stored in network byte order. The include file <netatalk/at.h> defines the AppleTalk address format. Sockets in the AppleTalk protocol family use the following address structure: struct sockaddr_at { uint8_t sat_len; sa_family_t sat_family; uint8_t sat_port; struct at_addr sat_addr; union { struct netrange r_netrange; char r_zero[8]; } sat_range; }; The port of a socket may be set with bind(2). The node for bind(2) must always be ATADDR_ANYNODE: ``this node''. The net must be ATADDR_ANYNET. ATADDR_ANYNET corresponds to the machine's ``primary'' address (the first configured). The port of a socket and the primary address are returned with getsockname(2). PROTOCOLS
The AppleTalk protocol family comprises the DDP datagram delivery protocol, AppleTalk Data Stream Protocol (ADSP), AppleTalk Echo Protocol (AEP), AppleTalk Filing Protocol (AFP), AppleTalk Session Protocol (ASP), AppleTalk Transaction Protocol (ATP), Name Binding Protocol (NBP), Printer Access Protocol (PAP), and Zone Information Protocol (ZIP). DDP is implemented in the kernel as SOCK_DGRAM sockets in the AF_APPLETALK address family. NetBSD implements all other AppleTalk protocols using the Netatalk package. Netatalk implements all functions except for ADSP and an AFP client. AEP, NBP, and ZIP services are provided by the atalkd daemon. ASP and ATP services are provided by a user library. PAP and AFP services are provided by user programs and daemons. SEE ALSO
bind(2), getsockname(2), options(4) Gursharan S. Sidhu, Richard F. Andrews, and Alan B. Oppenheimer, Inside AppleTalk, second edition. BSD
November 14, 1997 BSD

Check Out this Related Man Page

ATALKD(8)							   Netatalk 2.2 							 ATALKD(8)

NAME
atalkd - AppleTalk RTMP, NBP, ZIP, and AEP manager SYNOPSIS
atalkd [-f configfile] [-1] [-2] DESCRIPTION
atalkd is responsible for all user level AppleTalk network management. This includes routing, name registration and lookup, zone lookup, and the AppleTalk Echo Protocol (similar to ping(8)). atalkd is typically started at boot time, out of /etc/rc. It first reads from its configuration file, /etc/netatalk/atalkd.conf. If there is no configuration file, atalkd will attempt to configure all available interfaces and will create a configuration file. The file consists of a series of interfaces, one per line. Lines with `#' in the first column are ignored, as are blank lines. The syntax is interface [ -seed ] [ -phase number ] [ -net net-range ] [ -addr address ] [ -zone zonename ] ... Note that all fields except the interface are optional. The loopback interface is configured automatically. If -seed is specified, all other fields must be present. Also, atalkd will exit during bootstrapping, if a router disagrees with its seed information. If -seed is not given, all other information may be overriden during auto-configuration. If no -phase option is given, the default phase as given on the command line is used (the default is 2). If -addr is given and -net is not, a net-range of one is assumed. The first -zone directive for each interface is the ``default'' zone. Under Phase 1, there is only one zone. Under Phase 2, all routers on the network are configured with the default zone and must agree. atalkd maps ``*'' to the default zone of the first interface. Note: The default zone for a machine is determined by the configuration of the local routers; to appear in a non-default zone, each service, e.g. afpd, must individually specify the desired zone. See also nbp_name(3). ROUTING
If you are connecting a netatalk router to an existing AppleTalk internet, you should first contact your local network administrators to obtain appropriate network addresses. atalkd can provide routing between interfaces by configuring multiple interfaces. Each interface must be assigned a unique net-range between 1 and 65279 (0 and 65535 are illegal, and addresses between 65280 and 65534 are reserved for startup). It is best to choose the smallest useful net-range, i.e. if you have three machines on an Ethernet, don't chose a net-range of 1000-2000. Each net-range may have an arbitrary list of zones associated with it. EXAMPLES
Below is an example configuration file for a sun4/40. The machine has two interfaces, ``le0'' and ``le1''. The ``le0'' interface is configured automatically from other routers on the network. The machine is the only router for the ``le1'' interface. le0 le1 -seed -net 9461-9471 -zone netatalk -zone Argus atalkd automatically acts as a router if there is more than one interface. FILES
/etc/netatalk/atalkd.conf configuration file BUGS
On some systems, atalkd can not be restarted. SEE ALSO
atalkd.conf(5) Netatalk 2.2 06 Sep 2004 ATALKD(8)
Man Page