|Linux & Unix Commands - Search Man Pages
AMDTEMP(4) BSD Kernel Interfaces Manual AMDTEMP(4)
amdtemp -- AMD CPU on-die digital thermal sensor
amdtemp* at pchb?
The amdtemp driver provides support for the on-die digital thermal sensor present on AMD K8,
AMD Barcelona, AMD Phenom, AMD Griffin, and AMD Fusion CPUs.
These sensors were officially introduced in AMD K8 Revision F processors, and provide 0.5
degC accuracy. Precision was improved in Revision G chips, which provide two more bits for
0.25 degC steppings. Each core has two temperature sensors, and there are up to two cores
per CPU socket.
AMD Barcelona, AMD Phenom, AMD Griffin, and AMD Fusion provide 0.125 degC accuracy and pro-
vide one temperature sensor for each CPU socket.
The amdtemp driver reports temperatures through the envsys(4) API.
Sensor Units Typical Use
CPUN sensor0 uK cpuN temperature
envsys(4), envstat(8), powerd(8)
The amdtemp driver first appeared in OpenBSD 4.4 named ``kate''. It was then ported to
NetBSD 5.0. The driver has been renamed with support for newer AMD CPUs.
The amdtemp driver was written by Constantine A. Murenin <email@example.com> whilst at the
University of Waterloo. It was adapted to NetBSD by Christoph Egger.
BSD March 2, 2012 BSD
All times are GMT -4. The time now is 04:49 AM.