ADBMS(4) BSD Kernel Interfaces Manual ADBMS(4)NAME
adbms -- support for ADB mice, trackballs, and touchpads
SYNOPSIS
adbms* at nadb?
wsmouse* at adbms?
DESCRIPTION
The adbms driver handles most relative ADB pointing devices within the wscons(4) framework. For touchpads it also provides support for
translating tapping the pad to mouse button events.
Tapping support can be turned on or off on a per-device basis using sysctl(8):
machdep.adbms0.tapping
0 disables tapping, 1 enables it.
SEE ALSO nadb(4), wsmouse(4), wsconsctl(8)BSD May 14, 2007 BSD
Check Out this Related Man Page
WSMOUSE(4) BSD Kernel Interfaces Manual WSMOUSE(4)NAME
wsmouse -- generic mouse support in wscons
SYNOPSIS
wsmouse* at pms? mux 0
(PS/2 mouse, including ``IntelliMouse''-compatible wheel mice)
wsmouse* at ums? mux 0
(USB mouse)
wsmouse* at uts? mux 0
(USB touchscreen)
wsmouse* at lms? mux 0
(Logitech bus mouse, i386 only)
wsmouse* at mms? mux 0
(Microsoft InPort mouse, i386 only)
wsmouse0 at ams? mux 0
(Apple ADB mouse)
wsmouse* at btms? mux 0
(Bluetooth mouse)
wsmouse* at lkms? mux 0
(DEC VSXXX serial mice)
DESCRIPTION
The wsmouse driver is an abstraction layer for mice within the wscons(4) framework. It is attached to the hardware specific mouse drivers
and provides a character device interface which returns struct wscons_event via read(2). For use with X servers, ``mouse events'' can be
generated.
The wsconsctl(8) utility gives access to several configurable details that affect this driver.
Ioctls
The following ioctl(2) calls are provided by the wsmouse driver or by devices which use it. Their definitions are found in
dev/wscons/wsconsio.h.
WSMOUSEIO_GETREPEAT (struct wsmouse_repeat)
Retrieve the current automatic button repeating configuration. The structure returned is as follows:
struct wsmouse_repeat {
unsigned long wr_buttons;
unsigned int wr_delay_first;
unsigned int wr_delay_decrement;
unsigned int wr_delay_minimum;
};
The wr_buttons field is a bit mask that specifies which buttons send press and release events periodically while they are phys-
ically held down. The least significant bit corresponds to button 0.
The other three fields describe the frequency upon which these automatic events are sent. wr_delay_first specifies the mil-
liseconds before the first repeated event is sent. wr_delay_decrement is used to calculate the delay between the most recently
generated event and the forthcoming one: the previous delay is taken and it is decreased by the value given in this variable.
wr_delay_minimum specifies the minimum delay, in milliseconds, between two consecutive events.
WSMOUSEIO_SETREPEAT (struct wsmouse_repeat)
Set the automatic button repeating configuration. See WSMOUSEIO_GETREPEAT above for more details.
WSMOUSEIO_SETVERSION (int)
Set the wscons_event protocol version. The default is 0 for binary compatibility. The latest version is always available as
WSMOUSE_EVENT_VERSION, and is currently 1. All new code should use a call similar to the below to ensure the correct version
is returned.
int ver = WSMOUSE_EVENT_VERSION;
if (ioctl(fd, WSMOUSEIO_SETVERSION, &ver) == -1)
err(EXIT_FAILURE, "cannot set version");
FILES
/dev/wsmouse*
/usr/include/dev/wscons/wsconsio.h.
SEE ALSO btms(4), lms(4), mms(4), pms(4), uep(4), ums(4), uts(4), wscons(4), wsmux(4), moused(8), wsconsctl(8), wsmoused(8), wsmouse(9)BSD May 27, 2012 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)