hpux man page for scsi_hba_lookup_capstr

Query: scsi_hba_lookup_capstr

OS: hpux

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

scsi_hba_lookup_capstr(9F)				   Kernel Functions for Drivers 				scsi_hba_lookup_capstr(9F)

NAME
scsi_hba_lookup_capstr - return index matching capability string
SYNOPSIS
#include <sys/scsi/scsi.h> int scsi_hba_lookup_capstr(char *capstr);
INTERFACE LEVEL
Solaris architecture specific (Solaris DDI).
PARAMETERS
capstr Pointer to a string.
DESCRIPTION
scsi_hba_lookup_capstr() attempts to match capstr against a known set of capability strings, and returns the defined index for the matched capability, if found. The set of indices and capability strings is: SCSI_CAP_DMA_MAX "dma-max" or "dma_max" SCSI_CAP_MSG_OUT "msg-out" or "msg_out" SCSI_CAP_DISCONNECT "disconnect" SCSI_CAP_SYNCHRONOUS "synchronous" SCSI_CAP_WIDE_XFER "wide-xfer" or "wide_xfer" SCSI_CAP_PARITY "parity" SCSI_CAP_INITIATOR_ID "initiator-id" SCSI_CAP_UNTAGGED_QING "untagged-qing" SCSI_CAP_TAGGED_QING "tagged-qing" SCSI_CAP_ARQ "auto-rqsense" SCSI_CAP_LINKED_CMDS "linked-cmds" SCSI_CAP_SECTOR_SIZE "sector-size" SCSI_CAP_TOTAL_SECTORS "total-sectors" SCSI_CAP_GEOMETRY "geometry" SCSI_CAP_RESET_NOTIFICATION "reset-notification" SCSI_CAP_QFULL_RETRIES "qfull-retries" SCSI_CAP_QFULL_RETRY_INTERVAL "qfull-retry-interval" SCSI_CAP_LUN_RESET "lun-reset"
RETURN VALUES
scsi_hba_lookup_capstr() returns a non-negative index value corresponding to the capability string, or -1 if the string does not match any known capability.
CONTEXT
scsi_hba_lookup_capstr() can be called from user or interrupt context.
SEE ALSO
tran_getcap(9E), tran_setcap(9E), scsi_ifgetcap(9F), scsi_ifsetcap(9F), scsi_reset_notify(9F) Writing Device Drivers SunOS 5.10 12 Jul 2002 scsi_hba_lookup_capstr(9F)
Related Man Pages
scsi_hba_lookup_capstr(9f) - minix
scsi_hba_lookup_capstr(9f) - v7
scsi_hba_lookup_capstr(9f) - osx
scsi_hba_lookup_capstr(9f) - hpux
scsi_hba_lookup_capstr(9f) - bsd
Similar Topics in the Unix Linux Community
How to list file size on HPUX?
PHP Man Pages Now Available (Over 10,000)
How to extract every repeated string between two specific string?
SAN Migration question