VM_PAGE_ALLOC(9) BSD Kernel Developer's Manual VM_PAGE_ALLOC(9)NAME
vm_page_alloc -- allocate a page for a vm_object
SYNOPSIS
#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_page.h>
vm_page_t
vm_page_alloc(vm_object_t object, vm_pindex_t pindex, int req);
DESCRIPTION
The vm_page_alloc() function allocates a page at pindex within object. It is assumed that a page has not already been allocated at pindex.
The page returned is inserted into the object, unless VM_ALLOC_NOOBJ is specified in the req. The page may exist in the vm object cache, in
which case it will be reactivated instead, moving from the cache into the object page list.
vm_page_alloc() will not sleep.
Its arguments are:
object The VM object to allocate the page for. The object must be locked if VM_ALLOC_NOOBJ is not specified.
pindex The index into the object at which the page should be inserted.
req The bitwise-inclusive OR of a class and any optional flags indicating how the page should be allocated.
Exactly one of the following classes must be specified:
VM_ALLOC_NORMAL The page should be allocated with no special treatment.
VM_ALLOC_SYSTEM The page can be allocated if the cache is empty and the free page count is above the interrupt reserved water
mark. This flag should be used only when the system really needs the page.
VM_ALLOC_INTERRUPT vm_page_alloc() is being called during an interrupt. A page will be returned successfully if the free page count
is greater than zero.
The optional flags are:
VM_ALLOC_NOBUSY The returned page will not be exclusive busy.
VM_ALLOC_NODUMP The returned page will not be included in any kernel core dumps regardless of whether or not it is mapped in to
KVA.
VM_ALLOC_NOOBJ Do not associate the allocated page with a vm object. The object argument is ignored.
VM_ALLOC_IFCACHED Allocate the page only if it is cached. Otherwise, return NULL.
VM_ALLOC_IFNOTCACHED Only allocate the page if it is not cached in the object. If the page at the specified pindex is cached, NULL
is returned instead.
VM_ALLOC_SBUSY The returned page will be shared busy.
VM_ALLOC_WIRED The returned page will be wired.
VM_ALLOC_ZERO Indicate a preference for a pre-zeroed page. There is no guarantee that the returned page will be zeroed, but
it will have the PG_ZERO flag set if it is zeroed.
RETURN VALUES
The vm_page_t that was allocated is returned if successful; otherwise, NULL is returned.
NOTES
The pager process is always upgraded to VM_ALLOC_SYSTEM unless VM_ALLOC_INTERRUPT is set.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD January 28, 2012 BSD
Check Out this Related Man Page
VM_PAGE_BITS(9) BSD Kernel Developer's Manual VM_PAGE_BITS(9)NAME
vm_page_bits, vm_page_set_validclean, vm_page_clear_dirty, vm_page_set_invalid, vm_page_zero_invalid, vm_page_is_valid, vm_page_test_dirty,
vm_page_dirty, vm_page_undirty -- manage page clean and dirty bits
SYNOPSIS
#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_page.h>
int
vm_page_bits(int base, int size);
void
vm_page_set_validclean(vm_page_t m, int base, int size);
void
vm_page_clear_dirty(vm_page_t m, int base, int size);
void
vm_page_set_invalid(vm_page_t m, int base, int size);
void
vm_page_zero_invalid(vm_page_t m, boolean_t setvalid);
int
vm_page_is_valid(vm_page_t m, int base, int size);
void
vm_page_test_dirty(vm_page_t m);
void
vm_page_dirty(vm_page_t m);
void
vm_page_undirty(vm_page_t m);
DESCRIPTION
vm_page_bits() calculates the bits representing the DEV_BSIZE range of bytes between base and size. The byte range is expected to be within
a single page, and if size is zero, no bits will be set.
vm_page_set_validclean() flags the byte range between base and size as valid and clean. The range is expected to be DEV_BSIZE aligned and no
larger than PAGE_SIZE. If it is not properly aligned, any unaligned chucks of the DEV_BSIZE blocks at the beginning and end of the range
will be zeroed.
If base is zero and size is one page, the modified bit in the page map is cleared; as well, the VPO_NOSYNC flag is cleared.
vm_page_clear_dirty() clears the dirty bits within a page in the range between base and size. The bits representing the range are calculated
by calling vm_page_bits().
vm_page_set_invalid() clears the bits in both the valid and dirty flags representing the DEV_BSIZE blocks between base and size in the page.
The bits are calculated by calling vm_page_bits(). As well as clearing the bits within the page, the generation number within the object
holding the page is incremented.
vm_page_zero_invalid() zeroes all of the blocks within the page that are currently flagged as invalid. If setvalid is TRUE, all of the valid
bits within the page are set.
In some cases, such as NFS, the valid bits cannot be set in order to maintain cache consistency.
vm_page_is_valid() checks to determine if the all of the DEV_BSIZE blocks between base and size of the page are valid. If size is zero and
the page is entirely invalid vm_page_is_valid() will return TRUE, in all other cases a size of zero will return FALSE.
vm_page_test_dirty() checks if a page has been modified via any of its physical maps, and if so, flags the entire page as dirty.
vm_page_dirty() is called to modify the dirty bits.
vm_page_dirty() flags the entire page as dirty. It is expected that the page is not currently on the cache queue.
vm_page_undirty() clears all of the dirty bits in a page.
NOTES
None of these functions are allowed to block.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD December 1, 2001 BSD