freebsd man page for vm_map_simplify_entry

Query: vm_map_simplify_entry

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VM_MAP_SIMPLIFY_ENTRY(9)				   BSD Kernel Developer's Manual				  VM_MAP_SIMPLIFY_ENTRY(9)

NAME
vm_map_simplify_entry -- simplify a vm_map_entry
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_map.h> void vm_map_simplify_entry(vm_map_t map, vm_map_entry_t entry);
DESCRIPTION
The vm_map_simplify_entry() function simplifies the given entry by merging with either neighbour. The map must be locked upon entry. This function also has the ability to merge with both neighbours. This function guarantees that the passed entry remains valid, although possibly extended.
SEE ALSO
vm_map(9), vm_map_insert(9), vm_map_remove(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 19, 2003 BSD
Related Man Pages
vm_map_clean(9) - debian
vm_map_lookup(9) - debian
vm_map_check_protection(9) - freebsd
vm_map_lookup_done(9) - freebsd
vm_map_clean(9) - linux
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
Memory Leaks
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?
Controlling user input