VHOLD(9) BSD Kernel Developer's Manual VHOLD(9)NAME
vhold, vdrop, vdropl -- acquire/release a hold on a vnode
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
void
vhold(struct vnode *vp);
void
vholdl(struct vnode *vp);
void
vdrop(struct vnode *vp);
void
vdropl(struct vnode *vp);
DESCRIPTION
The vhold() and vholdl() functions increment the v_holdcnt of the given vnode. If the vnode has already been added to the free list and is
still referenced, it will be removed.
The vdrop() and vdropl() functions decrement the v_holdcnt of the vnode. If the holdcount is less than or equal to zero prior to calling
vdrop() or vdropl(), the system will panic. If the vnode is no longer referenced, it will be freed.
vhold() and vdrop() lock the vnode interlock while vholdl() and vdropl() expect the interlock to already be held.
SEE ALSO vnode(9)AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD April 1, 2007 BSD
Check Out this Related Man Page
VRELE(9) BSD Kernel Developer's Manual VRELE(9)NAME
vput, vrele, vunref -- decrement the use count for a vnode
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
void
vput(struct vnode *vp);
void
vrele(struct vnode *vp);
void
vunref(struct vnode *vp);
DESCRIPTION
Decrement the v_usecount field of a vnode.
vp the vnode to decrement
The vrele() function takes an unlocked vnode and returns with the vnode unlocked.
The vput() function should be given a locked vnode as argument, the vnode is unlocked after the function returned. The vput() is opera-
tionally equivalent to calling VOP_UNLOCK(9) followed by vrele(9), with less overhead.
The vunref() function takes a locked vnode as argument, and returns with the vnode locked.
Any code in the system which signified its use of a vnode by usecount should call one of the listed function to decrement use counter. If
the v_usecount field of the non-doomed vnode reaches zero, then it will be inactivated and placed on the free list. Since the functions
might need to call VOPs for the vnode, the Giant mutex should be conditionally locked around the call.
The hold count for the vnode is always greater or equal to the usecount. Non-forced unmount fails when mount point owns a vnode that has
non-zero usecount, see vflush(9).
SEE ALSO vget(9), vnode(9), vref(9), vrefcnt(9)AUTHORS
This manual page was written by Doug Rabson and
Konstantin Belousov.
BSD November 20, 2010 BSD
Introduction
Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
nwbqBdghh6E
The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component:
Vue.component("unix-time", {
template: `<div class="time">{{unixtime}}</div>`,
data() {
return {
unixtime: ""
};
},
methods: {
... (1 Reply)
i read here that linux provides no way to determine when a directory was created.
https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it.
That file says
I put the script in that directory and... (3 Replies)
Hello.
I can use any particular (stupid or not) format when using bash date command.
Example :
~> date --date "now" '+%Y-%m-%d %H!%M!%S'
2019-06-03 12!55!33or
~> date --date "now" '+%Y£%m£%d %H¤%M¤%S'
2019£06£03 12¤57¤36
or
~> date --date "now" '+%Y-%m-%d %H-%M-%S'
2019-06-03 12-58-51
... (4 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement?
for i in 1 2 3; do
echo "Ready?"
sleep 2
... (10 Replies)