Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

suword64(9) [freebsd man page]

STORE(9)						   BSD Kernel Developer's Manual						  STORE(9)

NAME
store, subyte, suswintr, suword -- store data to user-space SYNOPSIS
#include <sys/types.h> #include <sys/time.h> #include <sys/systm.h> int subyte(volatile void *base, int byte); int suword(volatile void *base, long word); int suword16(volatile void *base, int word); int suword32(volatile void *base, int32_t word); int suword64(volatile void *base, int64_t word); #include <sys/resourcevar.h> int suswintr(void *base, int word); DESCRIPTION
The store functions are designed to copy small amounts of data to user-space. If write is successful, it is performed atomically. The data written must be naturally aligned. The store routines provide the following functionality: subyte() Stores a byte of data to the user-space address base. suword() Stores a word of data to the user-space address base. suword16() Stores 16 bits of data to the user-space address base. suword32() Stores 32 bits of data to the user-space address base. suword64() Stores 64 bits of data to the user-space address base. suswintr() Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context. RETURN VALUES
The store functions return 0 on success or -1 on failure. SEE ALSO
copy(9), fetch(9) BSD
October 29, 2014 BSD

Check Out this Related Man Page

STORE(9)						   BSD Kernel Developer's Manual						  STORE(9)

NAME
store, subyte, suswintr, suword -- store data to user-space SYNOPSIS
#include <sys/types.h> #include <sys/time.h> #include <sys/systm.h> int subyte(volatile void *base, int byte); int suword(volatile void *base, long word); int suword16(volatile void *base, int word); int suword32(volatile void *base, int32_t word); int suword64(volatile void *base, int64_t word); #include <sys/resourcevar.h> int suswintr(void *base, int word); DESCRIPTION
The store functions are designed to copy small amounts of data to user-space. If write is successful, it is performed atomically. The data written must be naturally aligned. The store routines provide the following functionality: subyte() Stores a byte of data to the user-space address base. suword() Stores a word of data to the user-space address base. suword16() Stores 16 bits of data to the user-space address base. suword32() Stores 32 bits of data to the user-space address base. suword64() Stores 64 bits of data to the user-space address base. suswintr() Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context. RETURN VALUES
The store functions return 0 on success or -1 on failure. SEE ALSO
copy(9), fetch(9) BSD
October 29, 2014 BSD
Man Page

5 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

How to delete the last word in a file?

Hi All, I have a file with the data as below. In this i want to delete the last word. Could you pls help me. $INSTALL_HOME/lib/fm_voucher_pol.so $INSTALL_HOME/source/sys/fm_apn_pol/fm_apn_pol_device_set_state.c In the above two lines i want to delete fm_voucher_pol.so and... (5 Replies)
Discussion started by: girish.raos
5 Replies

2. Shell Programming and Scripting

Extracting a word from a variable

Hi Guys, Need you quick assistance on the below, trying to extract a word from a variable i.e. acmi101acmi102acmi103acmi104 When i use the following code awk '{gsub(/cmi102/,"")};1' it leaves a space in the variable, need to get rid of the space that it leaves. Any ideas. the above... (3 Replies)
Discussion started by: eo29
3 Replies

3. Shell Programming and Scripting

Grepping word based on white space.....

Hi, I am having a text file with following contents: word word I want to grep the first line i.e. word that is being preceded with three space characters. So i tried sed -n '/ {3}/p' filename grep " {3}" filename But is not returning any result. If i don't use {}, then it... (5 Replies)
Discussion started by: sarbjit
5 Replies

4. Shell Programming and Scripting

Awk for last word

Hi I am writing a script using nano and I'm asking the user for their full name, I then store this in a variable but I only want to display the last word that they input. Any idea on how I would do this using awk. I am not using sed, just using a script. So far I have got this... echo "What... (1 Reply)
Discussion started by: Addman1991
1 Replies

5. Cybersecurity

SSL Certificate Stores

Hey everyone, I'm trying to get a lay of the land for OS and Application Certificate Stores. Can someone confirm that I have this concept right? If the application you're using say Firefox has it's own trusted CA store, it uses that exclusively. So if you're running firefox in Windows, Firefox... (4 Replies)
Discussion started by: Lost in Cyberia
4 Replies