SECURELEVEL_GT(9) BSD Kernel Developer's Manual SECURELEVEL_GT(9)NAME
securelevel_gt, securelevel_ge -- test active securelevel
SYNOPSIS
#include <sys/types.h>
#include <sys/proc.h>
int
securelevel_gt(struct ucred *cr, int level);
int
securelevel_ge(struct ucred *cr, int level);
DESCRIPTION
These functions test the active security level against the given level. If the calling credential cr was imprisoned by the jail(2) system
call, and has a different security level set than the host environment, the security level with the highest value is used.
The securelevel_gt() function will evaluate whether or not the active security level is greater than the supplied level.
The securelevel_ge() function will evaluate whether or not the active security level is greater than or equal to the supplied level.
RETURN VALUES
These functions return EPERM if condition evaluated to true, and 0 otherwise.
SEE ALSO securelevel(7)BSD June 2, 2007 BSD
Check Out this Related Man Page
CR_SEEOTHERGIDS(9) BSD Kernel Developer's Manual CR_SEEOTHERGIDS(9)NAME
cr_seeothergids -- determine visibility of objects given their group memberships
SYNOPSIS
int
cr_seeothergids(struct ucred *u1, struct ucred *u2);
DESCRIPTION
This function determines the visibility of objects in the kernel based on the group IDs in the credentials u1 and u2 associated with them.
The visibility of objects is influenced by the sysctl(8) variable security.bsd.see_other_gids. If this variable is non-zero then all objects
in the kernel are visible to each other irrespective of their group membership. If this variable is zero then the object with credentials u2
is visible to the object with credentials u1 if either u1 is the super-user credential, or if at least one of u1's group IDs is present in
u2's group set.
SYSCTL VARIABLES
security.bsd.see_other_gids
Must be non-zero if objects with unprivileged credentials are to be able to see each other.
RETURN VALUES
This function returns zero if the object with credential u1 can ``see'' the object with credential u2, or ESRCH otherwise.
SEE ALSO cr_seeotheruids(9), p_candebug(9)BSD November 11, 2003 BSD
Introduction
Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
nwbqBdghh6E
The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component:
Vue.component("unix-time", {
template: `<div class="time">{{unixtime}}</div>`,
data() {
return {
unixtime: ""
};
},
methods: {
... (1 Reply)
i read here that linux provides no way to determine when a directory was created.
https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it.
That file says
I put the script in that directory and... (3 Replies)
Hello.
I can use any particular (stupid or not) format when using bash date command.
Example :
~> date --date "now" '+%Y-%m-%d %H!%M!%S'
2019-06-03 12!55!33or
~> date --date "now" '+%Y£%m£%d %H¤%M¤%S'
2019£06£03 12¤57¤36
or
~> date --date "now" '+%Y-%m-%d %H-%M-%S'
2019-06-03 12-58-51
... (4 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement?
for i in 1 2 3; do
echo "Ready?"
sleep 2
... (10 Replies)