Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

rijndael(9) [freebsd man page]

RIJNDAEL(9)						   BSD Kernel Developer's Manual					       RIJNDAEL(9)

NAME
rijndael_makeKey, rijndael_cipherInit, rijndael_blockEncrypt, rijndael_padEncrypt, rijndael_blockDecrypt, rijndael_padDecrypt -- AES encryp- tion SYNOPSIS
#include <sys/types.h> #include <crypto/rijndael.h> int rijndael_makeKey(keyInstance *key, uint8_t direction, int keyLen, char *keyMaterial); int rijndael_cipherInit(cipherInstance *cipher, uint8_t mode, char *IV); int rijndael_blockEncrypt(cipherInstance *cipher, keyInstance *key, uint8_t *input, int inputLen, uint8_t *outBuffer); int rijndael_padEncrypt(cipherInstance *cipher, keyInstance *key, uint8_t *input, int inputOctets, uint8_t *outBuffer); int rijndael_blockDecrypt(cipherInstance *cipher, keyInstance *key, uint8_t *input, int inputLen, uint8_t *outBuffer); int rijndael_padDecrypt(cipherInstance *cipher, keyInstance *key, uint8_t *input, int inputOctets, uint8_t *outBuffer); DESCRIPTION
The rijndael_makeKey() function is used to set up the key schedule in key. The direction (which may be DIR_ENCRYPT or DIR_DECRYPT) specifies the intended use of the key. The length of the key (in bits) is given in keyLen, and must be 128, 192 or 256. The actual key is supplied in the buffer pointed to by keyMaterial. This material may be raw binary data, or an ASCII string containing a hexadecimal rendition of the raw binary data, dependent on a compile-time option in the rijndael_makeKey sources, BINARY_KEY_MATERIAL. RETURN VALUES
The rijndael_makeKey() function will return BAD_KEY_INSTANCE if a NULL key is passed, BAD_KEY_DIR if direction is not DIR_ENCRYPT or DIR_DECRYPT, BAD_KEY_MAT if the key materials are not a hexadecimal string (and binary keys are not set), and TRUE otherwise. AUTHORS
Mark R V Murray BSD
February 6, 2002 BSD

Check Out this Related Man Page

xcb_input_grab_device_key(3)					   XCB Requests 				      xcb_input_grab_device_key(3)

NAME
xcb_input_grab_device_key - SYNOPSIS
#include <xcb/xinput.h> Request function xcb_void_cookie_t xcb_input_grab_device_key(xcb_connection_t *conn, xcb_window_t grab_window, uint16_t num_classes, uint16_t modifiers, uint8_t modifier_device, uint8_t grabbed_device, uint8_t key, uint8_t this_device_mode, uint8_t other_device_mode, uint8_t owner_events, const xcb_input_event_class_t *classes); REQUEST ARGUMENTS
conn The XCB connection to X11. grab_window TODO: NOT YET DOCUMENTED. num_classes TODO: NOT YET DOCUMENTED. modifiers TODO: NOT YET DOCUMENTED. modifier_device TODO: NOT YET DOCUMENTED. grabbed_device TODO: NOT YET DOCUMENTED. key TODO: NOT YET DOCUMENTED. this_device_mode TODO: NOT YET DOCUMENTED. other_device_mode TODO: NOT YET DOCUMENTED. owner_events TODO: NOT YET DOCUMENTED. classes TODO: NOT YET DOCUMENTED. DESCRIPTION
RETURN VALUE
Returns an xcb_void_cookie_t. Errors (if any) have to be handled in the event loop. If you want to handle errors directly with xcb_request_check instead, use xcb_input_grab_device_key_checked. See xcb-requests(3) for de- tails. ERRORS
This request does never generate any errors. SEE ALSO
AUTHOR
Generated from xinput.xml. Contact xcb@lists.freedesktop.org for corrections and improvements. XCB
2014-06-10 xcb_input_grab_device_key(3)
Man Page