freebsd man page for pmap_unwire

Query: pmap_unwire

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMAP_UNWIRE(9)						   BSD Kernel Developer's Manual					    PMAP_UNWIRE(9)

NAME
pmap_unwire -- unwire a range of virtual pages
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> void pmap_unwire(pmap_t pmap, vm_offset_t start, vm_offset_t end);
DESCRIPTION
The function pmap_unwire() removes the wired attribute from each of the virtual-to-physical page mappings within the virtual address range from start to end of the physical map pmap. Every valid mapping within that range is required to have the wired attribute set. Invalid map- pings are ignored, since they cannot have the wired attribute set.
NOTES
Only the function pmap_enter(9) can be used to set the wired attribute of a virtual-to-physical page mapping.
SEE ALSO
pmap(9), pmap_enter(9), pmap_wired_count(9)
AUTHORS
This manual page was written by Alan L. Cox <alc@rice.edu>.
BSD
July 17, 2014 BSD
Related Man Pages
pmap_extract(9) - debian
pmap_extract_and_hold(9) - debian
vm_fault_prefault(9) - debian
vm_map_unwire(9) - debian
vm_map_wire(9) - freebsd
Similar Topics in the Unix Linux Community
Unix File Permissions
Is UNIX an open source OS ?
UNIX Environment Setup - (Just starting!)
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?
Controlling user input