Query: panic
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
PANIC(9) BSD Kernel Developer's Manual PANIC(9)NAMEpanic -- bring down system on fatal errorSYNOPSIS#include <sys/types.h> #include <sys/systm.h> void panic(const char *fmt, ...);DESCRIPTIONThe panic() function terminates the running system. The message fmt is a printf(3) style format string. The message is printed to the con- sole and the location panicstr is set to the address of the message text for retrieval from the OS core dump. If the kernel debugger is installed control is passed to it, otherwise an attempt to save a core dump of the OS to a configured dump device is made. If panic() is called twice (from the disk sync routines, for example) the system is rebooted without syncing the disks.RETURN VALUESThe panic() function does not return.BSDAugust 11, 1995 BSD
Related Man Pages |
---|
savecore(8) - bsd |
panic(9) - netbsd |
vpanic(9) - netbsd |
ddi_in_panic(9f) - sunos |
ddi_in_panic(9f) - centos |