Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

module_depend(9) [freebsd man page]

MODULE_DEPEND(9)					   BSD Kernel Developer's Manual					  MODULE_DEPEND(9)

NAME
MODULE_DEPEND -- set kernel module dependencies SYNOPSIS
#include <sys/param.h> #include <sys/module.h> MODULE_DEPEND(name, moddepend, int minversion, int prefversion, int maxversion); DESCRIPTION
The MODULE_DEPEND() macro sets a dependency on another kernel module with name moddepend, which has registered its version with MODULE_VERSION(). The MODULE_DEPEND() macro provides hints to the kernel loader(8) and to the kernel linker to ensure that the named dependency is loaded prior to the existing module. It does not change or dictate the order in which modules are initialized at runtime. Three versions must be specified for moddepend: minversion The minimum version on which the current module can depend. maxversion The maximum version on which the current module can depend. prefversion The preferred version on which the current module can depend. EXAMPLES
MODULE_DEPEND(foo, bar, 1, 3, 4); SEE ALSO
DECLARE_MODULE(9), module(9), MODULE_VERSION(9) AUTHORS
This manual page was written by Alexander Langer <alex@FreeBSD.org>. BSD
January 11, 2005 BSD

Check Out this Related Man Page

SYSCALL_MODULE(9)					   BSD Kernel Developer's Manual					 SYSCALL_MODULE(9)

NAME
SYSCALL_MODULE -- syscall kernel module declaration macro SYNOPSIS
#include <sys/param.h> #include <sys/kernel.h> #include <sys/proc.h> #include <sys/module.h> #include <sys/sysent.h> SYSCALL_MODULE(name, int *offset, struct sysent *new_sysent, modeventhand_t evh, void *arg); DESCRIPTION
The SYSCALL_MODULE() macro declares a new syscall. SYSCALL_MODULE() expands into a kernel module declaration named as name. The rest of the arguments expected by this macro are: offset A pointer to an int which saves the offset in struct sysent where the syscall is allocated. new_sysent is a pointer to a structure that specifies the function implementing the syscall and the number of arguments this function needs (see <sys/sysent.h>). evh A pointer to the kernel module event handler function with the argument arg. Please refer to module(9) for more information. arg The argument passed to the callback functions of the evh event handler when it is called. EXAMPLES
A minimal example for a syscall module can be found in /usr/share/examples/kld/syscall/module/syscall.c. SEE ALSO
module(9) /usr/share/examples/kld/syscall/module/syscall.c AUTHORS
This manual page was written by Alexander Langer <alex@FreeBSD.org>. BSD
January 7, 2005 BSD
Man Page

3 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Kernel module compilation problem

I have one big module 2.6.18 kernel mod.c I want to divide this to several files. The problem is to write right Makefile lib1.h lib1.c mod.c mod.c works fine normally but when I divide into several files and try to compile with this makefile obj-m := mod.o mod-objs := lib1.o ... (3 Replies)
Discussion started by: marcintom
3 Replies

2. UNIX for Dummies Questions & Answers

hello world kermel module

How to implement hello world kernel module on ubuntu ?I want the hello.c and makefile file for the module and also steps for compilation and installation of the module.:wall: (1 Reply)
Discussion started by: pratibha
1 Replies

3. UNIX for Dummies Questions & Answers

insmod: Invalid module format error

I have open suse kernel kernel 3.1.0-1.2-desktop on which I used kernel source 3.1.10-1.2 downloaded from kernel.org. The module gets built. While loading a kernel module I am getting Invalid module format error with description "first_driver: no symbol version for module_layout" The... (5 Replies)
Discussion started by: rupeshkp728
5 Replies