Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

intro(9) [freebsd man page]

INTRO(9)						   BSD Kernel Developer's Manual						  INTRO(9)

NAME
intro -- introduction to system kernel interfaces DESCRIPTION
This section contains information about the interfaces and subroutines in the kernel. PROTOTYPES ANSI-C AND ALL THAT Yes please. We would like all code to be fully prototyped. If your code compiles cleanly with cc -Wall we would feel happy about it. It is important to understand that this is not a question of just shutting up cc, it is a question about avoiding the things it complains about. To put it bluntly, do not hide the problem by casting and other obfuscating practices, solve the problem. INDENTATION AND STYLE
Believe it or not, there actually exists a guide for indentation and style. It is not generally applied though. We would appreciate if people would pay attention to it, and at least not violate it blatantly. We do not mind it too badly if you have your own style, but please make sure we can read it too. Please take time to read style(9) for more information. NAMING THINGS
Some general rules exist: 1. If a function is meant as a debugging aid in DDB, it should be enclosed in #ifdef DDB #endif /* DDB */ And the name of the procedure should start with the prefix DDB_ to clearly identify the procedure as a debugger routine. SCOPE OF SYMBOLS
It is important to carefully consider the scope of symbols in the kernel. The default is to make everything static, unless some reason requires the opposite. There are several reasons for this policy, the main one is that the kernel is one monolithic name-space, and pollution is not a good idea here either. For device drivers and other modules that do not add new internal interfaces to the kernel, the entire source should be in one file if possi- ble. That way all symbols can be made static. If for some reason a module is split over multiple source files, then try to split the module along some major fault-line and consider using the number of global symbols as your guide. The fewer the better. SEE ALSO
style(9) HISTORY
The intro section manual page appeared in FreeBSD 2.2. BSD
December 13, 1995 BSD

Check Out this Related Man Page

TEXTDUMP(4)						   BSD Kernel Interfaces Manual 					       TEXTDUMP(4)

NAME
textdump -- textdump kernel dumping facility SYNOPSIS
options KDB options DDB DESCRIPTION
The textdump facility allows the capture of kernel debugging information to disk in a human-readable rather than the machine-readable form normally used with kernel memory dumps and minidumps. This representation, while less complete in that it does not capture full kernel state, can provide debugging information in a more compact, portable, and persistent form than a traditional dump. By combining textdump with other ddb(4) facilities, such as scripting and output capture, detailed bug information can be captured in a fully automated manner. FORMAT
textdump data is stored in a dump partition in the same style as a regular memory dump, and will be automatically extracted by savecore(8) if present on boot. textdump files are stored in the tar(5) format, and consist of one or more text files, each storing a particular type of debugging output. The following parts may be present: ddb.txt Captured ddb(4) output, if the capture facility has been used. May be disabled by clearing the debug.ddb.textdump.do_ddb sysctl. config.txt Kernel configuration, if has been compiled into the kernel. May be disabled by clearing the debug.ddb.textdump.do_config sysctl. msgbuf.txt Kernel message buffer, including recent console output if the capture facility has been used. May be disabled by clearing the debug.ddb.textdump.do_msgbuf sysctl. panic.txt Kernel panic string, if the kernel panicked before the dump was generated. May be disabled by clearing the debug.ddb.textdump.do_panic sysctl. version.txt Kernel version string. My be disabled by clearing the debug.ddb.textdump.do_version sysctl. Kernel textdumps may be extracted using tar(1). CONFIGURATION
The textdump facility is enabled as part of the kernel debugger using options KDB and options DDB. By default, kernel dumps generated on panic or via explicit requests for a dump will be regular memory dumps; however, by using the textdump set command in ddb(4), or by setting the debug.ddb.textdump.pending sysctl to 1 using sysctl(8), it is possible to request that the next dump be a textdump. If at the ddb(4) command line, the commands textdump set, textdump status, and textdump unset may be used to set, query, and clear the textdump pending flag. As with regular kernel dumps, a dump partition must be automatically or manually configured using dumpon(8). EXAMPLES
In the following example, the script kdb.enter.panic will run when the kernel debugger is entered as a result of a panic, enable output cap- ture, dump several useful pieces of debugging information, and then invoke panic in order to force a kernel dump to be written out followed by a reboot: script kdb.enter.panic=textdump set; capture on; show allpcpu; bt; ps; alltrace; show alllock; call doadump; reset In the following example, the script kdb.enter.witness will run when the kernel debugger is entered as a result of a witness violation, printing lock-related information for the user: script kdb.enter.witness=show locks These scripts may also be configured using the ddb(8) utility. SEE ALSO
tar(1), ddb(4), tar(5), ddb(8), dumpon(8), savecore(8), sysctl(8) HISTORY
The textdump facility first appeared in FreeBSD 7.1. AUTHORS
The textdump facility was created by Robert N. M. Watson. BSD
December 24, 2008 BSD
Man Page