Query: inittodr
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
INITTODR(9) BSD Kernel Developer's Manual INITTODR(9)NAMEinittodr -- initialize system timeSYNOPSIS#include <sys/types.h> #include <sys/systm.h> void inittodr(time_t base);DESCRIPTIONThe inittodr() function determines the time and sets the system clock. It tries to pick the correct time using a set of heuristics that examine the system's battery backed clock and the time obtained from the root file system, as given in base. How the base value is obtained will vary depending on the root file system type. The heuristics used include: o If the battery-backed clock has a valid time, it is used. o If the battery-backed clock does not have a valid time, the time provided in base will be used. Once a system time has been determined, it is stored in the time variable.DIAGNOSTICSThe inittodr() function prints diagnostic messages if it has trouble figuring out the system time. Conditions that can cause diagnostic mes- sages to be printed include: o The battery-backed clock's time appears nonsensical.SEE ALSOresettodr(9), time(9)BUGSOn many systems, inittodr() has to convert from a time expressed in terms of year, month, day, hours, minutes, and seconds to time, expressed in seconds. Many of the implementations could share code, but do not. Each system's heuristics for picking the correct time are slightly different. The FreeBSD implementation should do a better job of validating the time provided in base when the battery-backed clock is unusable. Cur- rently it unconditionally sets the system clock to this value.BSDMarch 22, 1997 BSD
Related Man Pages |
---|
alevt-date(1) - suse |
clock(3c) - hpux |
getbintime(9) - netbsd |
getmicrotime(9) - netbsd |
time_uptime(9) - netbsd |
Similar Topics in the Unix Linux Community |
---|
Correcting system time |
c/c++ clock like , battery charging |
how to get the same time in two systems, |
Clock doesn't tick |
how can i change inactive backed up filename on tsm |