Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

getmicrouptime(9) [freebsd man page]

MICROUPTIME(9)						   BSD Kernel Developer's Manual					    MICROUPTIME(9)

NAME
binuptime, getbinuptime, microuptime, getmicrouptime, nanouptime, getnanouptime, sbinuptime, getsbinuptime -- get the time elapsed since boot SYNOPSIS
#include <sys/time.h> void binuptime(struct bintime *bt); void getbinuptime(struct bintime *bt); void microuptime(struct timeval *tv); void getmicrouptime(struct timeval *tv); void nanouptime(struct timespec *ts); void getnanouptime(struct timespec *tsp); sbintime_t sbinuptime(void); sbintime_t getsbinuptime(void); DESCRIPTION
The binuptime() and getbinuptime() functions store the time elapsed since boot as a struct bintime at the address specified by bt. The microuptime() and getmicrouptime() functions perform the same utility, but record the elapsed time as a struct timeval instead. Similarly the nanouptime() and getnanouptime() functions store the elapsed time as a struct timespec. The sbinuptime() and getsbinuptime() functions return the time elapsed since boot as a sbintime_t. The binuptime(), microuptime(), nanouptime(), and sbinuptime() functions always query the timecounter to return the current time as precisely as possible. Whereas getbinuptime(), getmicrouptime(), getnanouptime(), and getsbinuptime() functions are abstractions which return a less precise, but faster to obtain, time. The intent of the getbinuptime(), getmicrouptime(), getnanouptime(), and getsbinuptime() functions is to enforce the user's preference for timer accuracy versus execution time. SEE ALSO
bintime(9), getbintime(9), getmicrotime(9), getnanotime(9), microtime(9), nanotime(9), tvtohz(9) AUTHORS
This manual page was written by Kelly Yancey <kbyanc@posi.net>. BSD
July 25, 2013 BSD

Check Out this Related Man Page

MICROTIME(9)						   BSD Kernel Developer's Manual					      MICROTIME(9)

NAME
bintime, getbintime, microtime, getmicrotime, nanotime, getnanotime -- get the current time SYNOPSIS
#include <sys/time.h> void bintime(struct bintime *bt); void getbintime(struct bintime *bt); void microtime(struct timeval *tv); void getmicrotime(struct timeval *tv); void nanotime(struct timespec *ts); void getnanotime(struct timespec *tsp); DESCRIPTION
The bintime() and getbintime() functions store the system time as a struct bintime at the addresses specified by bt. The microtime() and getmicrotime() functions perform the same utility, but record the time as a struct timeval instead. Similarly the nanotime() and getnanotime() functions store the time as a struct timespec. The structures are described in timeval(3). The bintime(), microtime(), and nanotime() functions always query the timecounter to return the current time as precisely as possible. Whereas getbintime(), getmicrotime(), and getnanotime() functions are abstractions which return a less precise, but faster to obtain, time. The intent of the getbintime(), getmicrotime(), and getnanotime() functions is to enforce the user's preference for timer accuracy versus execution time. They should be used where a precision of 1/HZ (e.g., 10 msec on a 100HZ machine, see hz(9)) is acceptable or where perfor- mance is priority. The system realtime clock is guaranteed to be monotonically increasing at all times. As such, all calls to these functions are guaranteed to return a system time greater than or equal to the system time returned in any previous calls. Comparable functions exist to retrieve the time elapsed since boot; see microuptime(9). SEE ALSO
settimeofday(2), bintime_add(9), inittodr(9), time_second(9), tvtohz(9) CODE REFERENCES
The implementation of the microtime() family of functions is in sys/kern/kern_tc.c as a part of the timecounter(9) framework. The implementation of the time counter sources used by the timecounter(9) is machine dependent, hence its location in the source code tree varies from architecture to architecture. AUTHORS
This manual page was written by Jeremy Cooper and Kelly Yancey <kbyanc@posi.net>. BUGS
Despite the guarantee that the system realtime clock will always be monotonically increasing, it is always possible for the system clock to be manually reset by the system administrator to any date. BSD
June 8, 2010 BSD
Man Page