Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

g_data(9) [freebsd man page]

G_DATA(9)						   BSD Kernel Developer's Manual						 G_DATA(9)

NAME
g_read_data, g_write_data -- read/write data from/to GEOM consumer SYNOPSIS
#include <geom/geom.h> void * g_read_data(struct g_consumer *cp, off_t offset, off_t length, int *error); int g_write_data(struct g_consumer *cp, off_t offset, void *ptr, off_t length); DESCRIPTION
The g_read_data() function reads length bytes of data from the provider attached to consumer cp, starting at offset offset. The buffer returned from g_read_data() is allocated with g_malloc(), so it should be freed by the caller with g_free() after use. If the operation fails, an error value will be stored in the error argument if it is not NULL. The g_write_data() function writes length bytes of data from the buffer pointed to by ptr to the provider attached to consumer cp, starting at offset offset. RESTRICTIONS
/CONDITIONS The length argument should be a multiple of the provider's sectorsize and less than or equal to DFLTPHYS (DFLTPHYS is defined in <sys/param.h>). The topology lock must not be held. RETURN VALUES
The g_read_data() function returns a pointer to a data buffer or NULL if an error occurred. In that case an error value is stored in the error argument unless it is NULL. The g_write_data() function returns 0 if successful; otherwise an error code is returned. ERRORS
Possible errors: [EIO] An I/O error occurred while reading from or writing to the consumer. SEE ALSO
geom(4), DECLARE_GEOM_CLASS(9), g_access(9), g_attach(9), g_bio(9), g_consumer(9), g_event(9), g_geom(9), g_provider(9), g_provider_by_name(9), g_wither_geom(9) AUTHORS
This manual page was written by Pawel Jakub Dawidek <pjd@FreeBSD.org>. BSD
January 16, 2004 BSD

Check Out this Related Man Page

G_CONSUMER(9)						   BSD Kernel Developer's Manual					     G_CONSUMER(9)

NAME
g_new_consumer, g_destroy_consumer -- GEOM consumers management SYNOPSIS
#include <geom/geom.h> struct g_consumer * g_new_consumer(struct g_geom *gp); void g_destroy_consumer(struct g_consumer *cp); DESCRIPTION
A GEOM consumer is the backdoor through which a geom connects to another GEOM provider and through which I/O requests are sent. The g_new_consumer() function creates a new consumer on geom gp. Before using the new consumer, it has to be attached to a provider with g_attach(9) and opened with g_access(9). The g_destroy_consumer() function destroys the given consumer and cancels all related pending events. This function is the last stage of killing an unwanted consumer. RESTRICTIONS
/CONDITIONS g_new_consumer(): The geom gp has to have an orphan method defined. The topology lock has to be held. g_destroy_consumer(): The consumer must not be attached to a provider. The access count has to be 0. The topology lock has to be held. RETURN VALUES
The g_new_consumer() function returns a pointer to the newly created consumer. EXAMPLES
Create consumer, attach it to given provider, gain read access and clean up. void some_function(struct g_geom *mygeom, struct g_provider *pp) { struct g_consumer *cp; g_topology_assert(); /* Create new consumer on 'mygeom' geom. */ cp = g_new_consumer(mygeom); /* Attach newly created consumer to given provider. */ if (g_attach(cp, pp) != 0) { g_destroy_consumer(cp); return; } /* Open provider for reading through our consumer. */ if (g_access(cp, 1, 0, 0) != 0) { g_detach(cp); g_destroy_consumer(cp); return; } g_topology_unlock(); /* * Read data from provider. */ g_topology_lock(); /* Disconnect from provider (release access count). */ g_access(cp, -1, 0, 0); /* Detach from provider. */ g_detach(cp); /* Destroy consumer. */ g_destroy_consumer(cp); } SEE ALSO
geom(4), DECLARE_GEOM_CLASS(9), g_access(9), g_attach(9), g_bio(9), g_data(9), g_event(9), g_geom(9), g_provider(9), g_provider_by_name(9), g_wither_geom(9) AUTHORS
This manual page was written by Pawel Jakub Dawidek <pjd@FreeBSD.org>. BSD
January 16, 2004 BSD
Man Page