DEVICE_SET_DESC(9) BSD Kernel Developer's Manual DEVICE_SET_DESC(9)NAME
device_set_desc, device_set_desc_copy, device_get_desc -- access the description of a device
SYNOPSIS
#include <sys/param.h>
#include <sys/bus.h>
void
device_set_desc(device_t dev, const char *desc);
void
device_set_desc_copy(device_t dev, const char *desc);
const char *
device_get_desc(device_t dev);
DESCRIPTION
Manipulate the verbose description of a device. This description (if present) is printed as part of the message when it is attached during
autoconfiguration. The variation device_set_desc_copy() is used to set the description if the string passed is a temporary buffer which will
be overwritten. In this case, the system will copy the string, otherwise the pointer passed will be used directly.
SEE ALSO device(9)AUTHORS
This manual page was written by Doug Rabson.
BSD June 16, 1998 BSD
Check Out this Related Man Page
DEVICE(9) BSD Kernel Developer's Manual DEVICE(9)NAME
device -- an abstract representation of a device
SYNOPSIS
typedef struct device *device_t;
DESCRIPTION
The device object represents a piece of hardware attached to the system such as an expansion card, the bus which that card is plugged into,
disk drives attached to the expansion card etc. The system defines one device, root_bus and all other devices are created dynamically during
autoconfiguration. Normally devices representing top-level busses in the system (ISA, PCI etc.) will be attached directly to root_bus and
other devices will be added as children of their relevant bus.
The devices in a system form a tree. All devices except root_bus have a parent (see device_get_parent(9)). In addition, any device can have
children attached to it (see device_add_child(9), device_add_child_ordered(9), device_find_child(9), device_get_children(9), and
device_delete_child(9)).
A device which has been successfully probed and attached to the system will also have a driver (see device_get_driver(9) and driver(9)) and a
devclass (see device_get_devclass(9) and devclass(9)). Various other attributes of the device include a unit number (see
device_get_unit(9)), verbose description (normally supplied by the driver, see device_set_desc(9) and device_get_desc(9)), a set of bus-spe-
cific variables (see device_get_ivars(9)) and a set of driver-specific variables (see device_get_softc(9)).
Devices can be in one of several states:
DS_NOTPRESENT the device has not been probed for existence or the probe failed
DS_ALIVE the device probe succeeded but not yet attached
DS_ATTACHED the device has been successfully attached
DS_BUSY the device is currently open
The current state of the device can be determined by calling device_get_state(9).
SEE ALSO devclass(9), driver(9)AUTHORS
This manual page was written by Doug Rabson.
BSD June 16, 1998 BSD
Introduction
Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
nwbqBdghh6E
The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component:
Vue.component("unix-time", {
template: `<div class="time">{{unixtime}}</div>`,
data() {
return {
unixtime: ""
};
},
methods: {
... (1 Reply)
i read here that linux provides no way to determine when a directory was created.
https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it.
That file says
I put the script in that directory and... (3 Replies)
Hello.
I can use any particular (stupid or not) format when using bash date command.
Example :
~> date --date "now" '+%Y-%m-%d %H!%M!%S'
2019-06-03 12!55!33or
~> date --date "now" '+%Y£%m£%d %H¤%M¤%S'
2019£06£03 12¤57¤36
or
~> date --date "now" '+%Y-%m-%d %H-%M-%S'
2019-06-03 12-58-51
... (4 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement?
for i in 1 2 3; do
echo "Ready?"
sleep 2
... (10 Replies)