DEVICE_QUIET(9) BSD Kernel Developer's Manual DEVICE_QUIET(9)NAME
device_quiet, device_verbose, device_is_quiet -- manipulate device quiet flag
SYNOPSIS
#include <sys/param.h>
#include <sys/bus.h>
void
device_quiet(device_t dev);
void
device_verbose(device_t dev);
int
device_is_quiet(device_t dev);
DESCRIPTION
Each device has a quiet flag associated with it. A device is verbose by default when it is created but may be quieted to prevent the device
identification string to be printed during probe. To quiet a device, call device_quiet(), to re-enable to probe message (to make the message
appear again, for example after a device_detach(9)) call device_verbose(). To test to see if a device is quieted, call device_is_quiet().
SEE ALSO device(9)AUTHORS
This manual page was written by Doug Rabson.
BSD June 21, 1999 BSD
Check Out this Related Man Page
DEVICE_GET_STATE(9) BSD Kernel Developer's Manual DEVICE_GET_STATE(9)NAME
device_get_state, device_busy, device_unbusy, device_is_alive, device_is_attached -- manipulate device state
SYNOPSIS
#include <sys/param.h>
#include <sys/bus.h>
device_state_t
device_get_state(device_t dev);
void
device_busy(device_t dev);
void
device_unbusy(device_t dev);
int
device_is_alive(device_t dev);
int
device_is_attached(device_t dev);
DESCRIPTION
The current state of a device is accessed by calling device_get_state() which returns DS_NOTPRESENT, DS_ALIVE, DS_ATTACHED or DS_BUSY
(described in device(9)). To test see if a device was successfully probed, call device_is_alive() which simply returns if the state is
greater or equal to DS_ALIVE. To test see if a device was successfully attached, call device_is_attached() which simply returns if the state
is greater or equal to DS_ATTACHED.
Each device has a busy count which is incremented when device_busy() is called and decremented when device_unbusy() is called. Both routines
return an error if the device state is less than DS_ATTACHED.
When device_busy() is called on a device in the DS_ATTACHED state, the device changes to the DS_BUSY state. When device_unbusy() is called
and after decrementing, the busy count for the device is zero, the device changes to the DS_ATTACHED state.
SEE ALSO device(9)AUTHORS
This manual page was written by Doug Rabson.
BSD June 16, 1998 BSD
Introduction
Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
nwbqBdghh6E
The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component:
Vue.component("unix-time", {
template: `<div class="time">{{unixtime}}</div>`,
data() {
return {
unixtime: ""
};
},
methods: {
... (1 Reply)
i read here that linux provides no way to determine when a directory was created.
https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it.
That file says
I put the script in that directory and... (3 Replies)
Hello.
I can use any particular (stupid or not) format when using bash date command.
Example :
~> date --date "now" '+%Y-%m-%d %H!%M!%S'
2019-06-03 12!55!33or
~> date --date "now" '+%Y£%m£%d %H¤%M¤%S'
2019£06£03 12¤57¤36
or
~> date --date "now" '+%Y-%m-%d %H-%M-%S'
2019-06-03 12-58-51
... (4 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement?
for i in 1 2 3; do
echo "Ready?"
sleep 2
... (10 Replies)