freebsd man page for device_probe_and_attach

Query: device_probe_and_attach

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVICE_PROBE_AND_ATTACH(9)				   BSD Kernel Developer's Manual				DEVICE_PROBE_AND_ATTACH(9)

NAME
device_probe_and_attach -- initialise a device
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int device_probe_and_attach(device_t dev);
DESCRIPTION
This function is called during autoconfiguration to initialise the devices in the system. For each device, the DEVICE_PROBE(9) method of each suitable driver is called and if a probe succeeds, a description of the device is printed and the DEVICE_ATTACH(9) method is called. If the device is disabled using device_disable(9) then it will not be probed.
RETURN VALUES
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSO
device(9), driver(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
June 16, 1998 BSD
Related Man Pages
device_get_softc(9) - minix
device_detach(9) - linux
device_attach(9) - osx
device_detach(9) - osx
device_detach(9) - minix
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Memory Leaks
Reason for no directory creation date
Valid separator in time and date format