freebsd man page for device_get_desc

Query: device_get_desc

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVICE_SET_DESC(9)					   BSD Kernel Developer's Manual					DEVICE_SET_DESC(9)

NAME
device_set_desc, device_set_desc_copy, device_get_desc -- access the description of a device
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> void device_set_desc(device_t dev, const char *desc); void device_set_desc_copy(device_t dev, const char *desc); const char * device_get_desc(device_t dev);
DESCRIPTION
Manipulate the verbose description of a device. This description (if present) is printed as part of the message when it is attached during autoconfiguration. The variation device_set_desc_copy() is used to set the description if the string passed is a temporary buffer which will be overwritten. In this case, the system will copy the string, otherwise the pointer passed will be used directly.
SEE ALSO
device(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
June 16, 1998 BSD
Related Man Pages
device(9) - debian
device(9) - linux
device(9) - minix
device(9) - bsd
device(9) - osx
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?