freebsd man page for device_find_child

Query: device_find_child

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVICE_FIND_CHILD(9)					   BSD Kernel Developer's Manual				      DEVICE_FIND_CHILD(9)

NAME
device_find_child -- search for a child of a device
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> device_t device_find_child(device_t dev, const char *classname, int unit);
DESCRIPTION
This function looks for a specific child of dev with the given classname and unit. If unit is -1, it returns the first child of dev with a matching classname (that is, the one with the lowest unit).
RETURN VALUES
If it exists, the child device is returned, otherwise NULL.
SEE ALSO
device_add_child(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
February 8, 2005 BSD
Related Man Pages
bus_add_child(9) - freebsd
device_add_child_ordered(9) - freebsd
device_add_child(9) - linux
device_add_child_ordered(9) - hpux
device_add_child(9) - hpux
Similar Topics in the Unix Linux Community
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Scripts without shebang
Reason for no directory creation date
Valid separator in time and date format
UNIX Environment Setup - (Just starting!)