freebsd man page for devclass_get_maxunit

Query: devclass_get_maxunit

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVCLASS_GET_MAXUNIT(9) 				   BSD Kernel Developer's Manual				   DEVCLASS_GET_MAXUNIT(9)

NAME
devclass_get_maxunit -- find the maximum unit number in the class
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int devclass_get_maxunit(devclass_t dc);
DESCRIPTION
Returns the next unit number to be allocated to device instances in the devclass. This is one greater than the highest currently allocated unit.
RETURN VALUES
The devclass_get_maxunit() function returns -1 if dc is NULL, otherwise it returns the next unit number in dc's devclass.
ERRORS
None.
SEE ALSO
devclass(9), device(9)
AUTHORS
This manual page was written by Doug Rabson.
BUGS
The name is confusing since it is one greater than the maximum unit.
BSD
September 10, 2010 BSD
Related Man Pages
device_add_child_ordered(9) - freebsd
device_add_child_ordered(9) - centos
devclass(9) - centos
devclass(9) - linux
devclass(9) - hpux
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
A simple UNIXtime component in Vue.js
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?
Controlling user input