freebsd man page for devclass_get_device

Query: devclass_get_device

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVCLASS_GET_DEVICE(9)					   BSD Kernel Developer's Manual				    DEVCLASS_GET_DEVICE(9)

NAME
devclass_get_device -- translate unit number to device
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> device_t devclass_get_device(devclass_t dc, int unit);
DESCRIPTION
This function retrieves the device instance with the given unit number and returns it.
RETURN VALUES
If the device exists, it is returned, otherwise NULL is returned.
SEE ALSO
devclass(9), device(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
June 16, 1998 BSD
Related Man Pages
device_add_child(9) - debian
device_add_child_ordered(9) - debian
devclass(9) - minix
devclass(9) - bsd
devclass(9) - osx
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Memory Leaks
A simple UNIXtime component in Vue.js
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?