freebsd man page for bus_generic_print_child

Query: bus_generic_print_child

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUS_GENERIC_PRINT_CHILD(9)				   BSD Kernel Developer's Manual				BUS_GENERIC_PRINT_CHILD(9)

NAME
bus_generic_print_child -- generic implementation of DEVICE_PRINT_CHILD for busses
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int bus_generic_print_child(device_t dev, device_t child);
DESCRIPTION
This implementation prints out the default device announcement message. Given device 'foo0' on bus 'bar0' where foo0 has the name "FooCard 1234" the following would be printed: foo0: <FooCard 1234> on bar0 bus_generic_print_child itself calls two functions bus_print_child_header() and bus_print_child_footer(). The former prints "foo0: <FooCard 1234>" and the latter "on bar0". These routines should be used if possible in your own code if bus_generic_print_child() does not completely suit your needs.
RETURN VALUES
The number of characters output.
SEE ALSO
device(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
June 16, 1998 BSD
Related Man Pages
device_busy(9) - debian
device_is_attached(9) - freebsd
device_get_state(9) - centos
device_get_state(9) - linux
device_get_state(9) - hpux
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
A simple UNIXtime component in Vue.js
UNIX Environment Setup - (Just starting!)
Controlling user input