freebsd man page for bus_generic_new_pass

Query: bus_generic_new_pass

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUS_GENERIC_NEW_PASS(9) 				   BSD Kernel Developer's Manual				   BUS_GENERIC_NEW_PASS(9)

NAME
bus_generic_new_pass -- generic implementation of BUS_NEW_PASS for bus devices
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> void bus_generic_new_pass(device_t dev);
DESCRIPTION
This function provides an implementation of the BUS_NEW_PASS(9) method which can be used by bus drivers. It first invokes the DEVICE_IDENTIFY(9) method for any drivers whose pass level is equal to the new pass level. Then, for each attached child device it calls BUS_NEW_PASS(9) to rescan child busses, and for each unattached child device it calls device_probe_and_attach(9).
SEE ALSO
BUS_NEW_PASS(9), bus_set_pass(9), device(9), DEVICE_IDENTIFY(9)
BSD
June 8, 2009 BSD
Related Man Pages
device_add_child_ordered(9) - linux
device_add_child_ordered(9) - hpux
device_add_child(9) - hpux
device_identify(9) - osx
device_identify(9) - hpux
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
A simple UNIXtime component in Vue.js
UNIX Environment Setup - (Just starting!)