BUF_LOCKFREE(9) BSD Kernel Developer's Manual BUF_LOCKFREE(9)NAME
BUF_LOCKFREE -- destroys a buffer's lock
SYNOPSIS
#include <sys/param.h>
#include <sys/systm.h>
#include <sys/uio.h>
#include <sys/bio.h>
#include <sys/buf.h>
void
BUF_LOCKFREE(struct buf *bp);
DESCRIPTION
The BUF_LOCKFREE() macro destroys the buffer lock. The lock must not be held when this macro is called or a panic will result.
Its argument is:
bp The buffer whose lock is to be destroyed.
SEE ALSO buf(9), BUF_LOCK(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockdestroy(9)AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD July 9, 2001 BSD
Check Out this Related Man Page
PBUF(9) BSD Kernel Developer's Manual PBUF(9)NAME
pbuf, getpbuf, trypbuf, relpbuf -- functions for managing physical buffers
SYNOPSIS
#include <sys/param.h>
#include <sys/systm.h>
#include <sys/bio.h>
#include <sys/buf.h>
struct buf *
getpbuf(int *pfreecnt);
struct buf *
trypbuf(int *pfreecnt);
void
relpbuf(struct buf *bp, int *pfreecnt);
DESCRIPTION
These functions are used to allocate and release physical buffers.
The physical buffers are allocated at system startup and are maintained in a separate pool from the main system buffers. They are intended
for use by subsystems that cannot or should not be reliant on the main pool of buffers (for example the swap pager). The system allocates
between 16 and 256 physical buffers depending on the amount of memory in the system.
Each subsystem that allocates buffers via these calls is expected to manage its own percentage free counter. If the value is initialized to
-1 the number of buffers available to the subsystem is limited only by the number of physical buffers available. The number of buffers is
stored in nswbuf which is defined in <sys/buf.h> and initialized in cpu_startup(). A recommended initialization value is 1/2 nswbuf.
The getpbuf() function returns the first available buffer to the user. If there are no buffers available, getpbuf() will sleep waiting for
one to become available. If pfreecnt is zero, getpbuf() will sleep until it increases. pfreecnt is decremented prior to returning.
The trypbuf() function returns the first available buffer. If there are no buffers available, NULL is returned. As well, if pfreecnt is
zero, NULL is returned. pfreecnt is decremented prior to returning a valid buffer. If NULL is returned, pfreecnt is not modified.
The relpbuf() function releases the buffer back to the free list. If the buffers b_rcred or b_wcred structures are not NULL, they are freed.
See crfree(9).
pfreecnt is incremented prior to returning.
RETURN VALUES
getpbuf() and trypbuf() return a pointer to the buffer. In the case of trypbuf(), NULL can also be returned indicating that there are no
buffers available.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD July 9, 2001 BSD
Introduction
Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
nwbqBdghh6E
The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component:
Vue.component("unix-time", {
template: `<div class="time">{{unixtime}}</div>`,
data() {
return {
unixtime: ""
};
},
methods: {
... (1 Reply)
i read here that linux provides no way to determine when a directory was created.
https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it.
That file says
I put the script in that directory and... (3 Replies)
Hello.
I can use any particular (stupid or not) format when using bash date command.
Example :
~> date --date "now" '+%Y-%m-%d %H!%M!%S'
2019-06-03 12!55!33or
~> date --date "now" '+%Y£%m£%d %H¤%M¤%S'
2019£06£03 12¤57¤36
or
~> date --date "now" '+%Y-%m-%d %H-%M-%S'
2019-06-03 12-58-51
... (4 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement?
for i in 1 2 3; do
echo "Ready?"
sleep 2
... (10 Replies)