freebsd man page for vop_remove

Query: vop_remove

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_REMOVE(9)						   BSD Kernel Developer's Manual					     VOP_REMOVE(9)

NAME
VOP_REMOVE, VOP_RMDIR -- remove a file or directory
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_REMOVE(struct vnode *dvp, struct vnode *vp, struct componentname *cnp); int VOP_RMDIR(struct vnode *dvp, struct vnode *vp, struct componentname *cnp);
DESCRIPTION
These entry points remove files and directories respectively. The arguments are: dvp The vnode of the directory. vp The vnode of the file to be removed. cnp Pathname information about the file.
LOCKS
Both dvp and vp should be locked on entry and remain locked on return.
RETURN VALUES
Zero is returned on success, otherwise an error code is returned.
ERRORS
[EPERM] The file is immutable. [ENOTEMPTY] An attempt was made to remove a directory which is not empty.
SEE ALSO
vnode(9), VOP_LOOKUP(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
July 24, 1996 BSD
Related Man Pages
vop_symlink(9) - debian
vop_mkdir(9) - freebsd
vop_create(9) - centos
vop_mkdir(9) - opensolaris
vop_create(9) - minix
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Scripts without shebang
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?