freebsd man page for vop_reallocblks

Query: vop_reallocblks

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_REALLOCBLKS(9)					   BSD Kernel Developer's Manual					VOP_REALLOCBLKS(9)

NAME
VOP_REALLOCBLKS -- rearrange blocks in a file to be contiguous
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_REALLOCBLKS(struct vnode *vp, struct cluster_save *buflist);
DESCRIPTION
The arguments are: vp The file to manipulate. buflist A list of buffers to rearrange. This seems to be part of a work in progress.
RETURN VALUES
Zero is returned on success, otherwise an error is returned.
SEE ALSO
buf(9), vnode(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
July 24, 1996 BSD
Related Man Pages
vop_vptocnp(9) - freebsd
vop_fsync(9) - opensolaris
vop_fsync(9) - centos
vop_link(9) - minix
vop_link(9) - linux
Similar Topics in the Unix Linux Community
Memory Leaks
A simple UNIXtime component in Vue.js
Reason for no directory creation date
Valid separator in time and date format
UNIX Environment Setup - (Just starting!)