freebsd man page for vn_isdisk

Query: vn_isdisk

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VN_ISDISK(9)						   BSD Kernel Developer's Manual					      VN_ISDISK(9)

NAME
vn_isdisk -- checks if a vnode represents a disk
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int vn_isdisk(struct vnode *vp, int *errp);
DESCRIPTION
The vn_isdisk() function checks to see if vp represents a disk. In order for vp to be a disk, it must be a character device, v_rdev must be valid, and the cdevsw entry's flags must have D_DISK set. Its arguments are: vp The vnode to check. errp An integer pointer to store the error number in if the call fails.
RETURN VALUES
If the vnode represents a disk, 1 is returned; otherwise, 0 is returned and errp will contain the error number.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
July 9, 2001 BSD
Related Man Pages
vput(9) - debian
vunref(9) - debian
vunref(9) - freebsd
vrele(9) - opensolaris
vrele(9) - centos
Similar Topics in the Unix Linux Community
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Scripts without shebang
Memory Leaks
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?
Controlling user input