freebsd man page for vm_set_page_size

Query: vm_set_page_size

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VM_SET_PAGE_SIZE(9)					   BSD Kernel Developer's Manual				       VM_SET_PAGE_SIZE(9)

NAME
vm_set_page_size -- initialize the system page size
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_page.h> void vm_set_page_size(void);
DESCRIPTION
The vm_set_page_size() function initializes the system page size. If vm_cnt.v_page_size (see <sys/vmmeter.h>) equals 0, PAGE_SIZE is used; otherwise, the value stored in vm_cnt.v_page_size is used. If vm_cnt.v_page_size is not a power of two, the system will panic. vm_set_page_size() must be called prior to any page size dependent functions.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
March 21, 2014 BSD
Related Man Pages
vm_page_hold(9) - debian
vm_page_insert(9) - debian
vm_page_unhold(9) - debian
vm_page_hold(9) - osx
vm_page_hold(9) - hpux
Similar Topics in the Unix Linux Community
Unix File Permissions
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Scripts without shebang
A simple UNIXtime component in Vue.js
Controlling user input