freebsd man page for vm_page_rename

Query: vm_page_rename

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VM_PAGE_RENAME(9)					   BSD Kernel Developer's Manual					 VM_PAGE_RENAME(9)

NAME
vm_page_rename -- move a page
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_page.h> void vm_page_rename(vm_page_t m, vm_object_t new_object, vm_pindex_t new_pindex);
DESCRIPTION
The vm_page_rename() function removes a page from one object, and adds it to another at the given page index. The page is added to the given object, and is removed from the object that is currently associated with. If the page is currently on the cache queue it will be deactivated unless it is wired or unmanaged, in which case the deactivation will fail. The entire page is marked as dirty after the move. The arguments to vm_page_rename() are: m The page to move. new_object The object the page should be inserted into. new_pindex The page index into new_object at which the new page should be inserted.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
July 17, 2001 BSD
Related Man Pages
vm_page_free(9) - freebsd
vm_page_free_zero(9) - debian
vm_page_alloc(9) - freebsd
vm_page_try_to_free(9) - freebsd
vm_page_free(9) - opensolaris
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Memory Leaks
Reason for no directory creation date
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?