Query: vm_map_delete
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
VM_MAP_DELETE(9) BSD Kernel Developer's Manual VM_MAP_DELETE(9)NAMEvm_map_delete -- deallocate an address range from a mapSYNOPSIS#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_map.h> int vm_map_delete(vm_map_t map, vm_offset_t start, vm_offset_t end);DESCRIPTIONThe vm_map_delete() function deallocates the address range bounded by start and end from the map.IMPLEMENTATION NOTESThis function is for FreeBSD VM internal use only. The vm_map_remove(9) function should be called by FreeBSD VM consumers instead.RETURN VALUESThe vm_map_delete() function always returns KERN_SUCCESS.SEE ALSOvm_map(9), vm_map_remove(9)AUTHORSThis manual page was written by Bruce M Simpson <bms@spc.org>.BSDJuly 19, 2003 BSD
Related Man Pages |
---|
vm_map_submap(9) - debian |
vm_map_unwire(9) - debian |
vm_map_wire(9) - debian |
vm_map_submap(9) - linux |
vm_map_clean(9) - linux |
Similar Topics in the Unix Linux Community |
---|
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick |
Reason for no directory creation date |
UNIX Environment Setup - (Just starting!) |
Controlling user input |