freebsd man page for vfs_unmount

Query: vfs_unmount

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VFS_UNMOUNT(9)						   BSD Kernel Developer's Manual					    VFS_UNMOUNT(9)

NAME
VFS_UNMOUNT -- unmount a file system
SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_UNMOUNT(struct mount *mp, int mntflags);
DESCRIPTION
The VFS_UNMOUNT() macro unmounts a file system. The arguments it expects are: mp The file system. mntflags Bit-mask of flags for the unmount operation. The flags currently supported by VFS_UNMOUNT() are: MNT_FORCE Open files are forcibly closed before the file system is unmounted.
SEE ALSO
vflush(9), VFS(9), vnode(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
May 23, 2009 BSD
Related Man Pages
vfs_vget(9) - debian
vfs_checkexp(9) - netbsd
vfs_quotactl(9) - netbsd
vfs_suspendctl(9) - netbsd
vfs_vget(9) - freebsd
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Is UNIX an open source OS ?
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?