freebsd man page for vfs_rootmountalloc

Query: vfs_rootmountalloc

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VFS_ROOTMOUNTALLOC(9)					   BSD Kernel Developer's Manual				     VFS_ROOTMOUNTALLOC(9)

NAME
vfs_rootmountalloc -- allocate a root mount structure
SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> int vfs_rootmountalloc(char *fstypename, char *devname, struct mount **mpp);
DESCRIPTION
vfs_rootmountalloc() allocates a mount structure initialized from the vfsconf type that matches fstypename.
RETURN VALUES
If successful, 0 is returned and mpp points to the newly allocated mount structure. ENODEV is returned if fstypename is NULL or invalid.
SEE ALSO
vfsconf(9)
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
November 21, 2001 BSD
Related Man Pages
vfs_reinit(9) - netbsd
vfs_attach(9) - netbsd
vfs_export(9) - netbsd
vfs_export_lookup(9) - netbsd
vfs_mountalloc(9) - netbsd
Similar Topics in the Unix Linux Community
Unix File Permissions
The Whole Story on #! /usr/bin/ksh
Controlling user input