freebsd man page for vfs_mount

Query: vfs_mount

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VFS_MOUNT(9)						   BSD Kernel Developer's Manual					      VFS_MOUNT(9)

NAME
VFS_MOUNT -- mount a file system
SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_MOUNT(struct mount *mp);
DESCRIPTION
The VFS_MOUNT() macro mounts a file system into the system's namespace or updates the attributes of an already mounted file system. The arguments it expects are: mp Structure representing the file system. The VFS_MOUNT() macro is called both to mount new file systems and to change the attributes of an existing file system. If the MNT_UPDATE flag is set in mp->mnt_flag then the file system should update its internal state from the value of mp->mnt_flag. This can be used, for instance, to convert a read-only file system to read-write. It is also used by mountd(8) to update the NFS export information for the file system. If the MNT_UPDATE flag is not specified, then this is a newly mounted file system. The file system code should allocate and initialize any private data needed to represent the file system (it can use the mp->mnt_data field to store this information).
SEE ALSO
VFS(9), vnode(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
May 23, 2009 BSD
Related Man Pages
vfs_root(9) - netbsd
vfs_mount(9) - debian
vfs_vget(9) - debian
vfs_fhtovp(9) - linux
vfs_fhtovp(9) - suse
Similar Topics in the Unix Linux Community
change the name of a file system