Query: vfs_getvfs
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
VFS_GETVFS(9) BSD Kernel Developer's Manual VFS_GETVFS(9)NAMEvfs_getvfs -- returns a mount point given its file system identifierSYNOPSIS#include <sys/param.h> #include <sys/mount.h> struct mount * vfs_getvfs(fsid_t *fsid);DESCRIPTIONThe vfs_getvfs() function returns the mount point structure for a file system given its file system identifier. The file system ID should have been allocated by calling vfs_getnewfsid(9); otherwise, it will not be found. A major user of vfs_getvfs() is NFS, which uses the fsid as part of file handles in order to determine the file system a given RPC is for. If vfs_getvfs() fails to find the mount point related to fsid, the file system is considered stale.RETURN VALUESIf fsid is found, the mount point for the ID is returned; otherwise, NULL is returned.PSEUDOCODEif ((mp = vfs_getvfs(&fhp->fh_fsid)) == NULL) { error = ESTALE; goto out; }SEE ALSOvfs_getnewfsid(9)AUTHORSThis manual page was written by Chad David <davidc@acns.ab.ca>.BSDNovember 21, 2001 BSD
Related Man Pages |
---|
vfs_setpublicfs(9) - netbsd |
vfs_attach(9) - netbsd |
vfs_export(9) - netbsd |
vfs_getvfs(9) - netbsd |
vfs_mountroot(9) - netbsd |
Similar Topics in the Unix Linux Community |
---|
Mac OS X: Based on UNIX - Solid As a Rock |
The Whole Story on #! /usr/bin/ksh |
A simple UNIXtime component in Vue.js |
Reason for no directory creation date |