Query: vfs_busy
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
VFS_BUSY(9) BSD Kernel Developer's Manual VFS_BUSY(9)NAMEvfs_busy -- marks a mount point as busySYNOPSIS#include <sys/param.h> #include <sys/mount.h> int vfs_busy(struct mount *mp, int flags);DESCRIPTIONThe vfs_busy() function marks a mount point as busy by incrementing the reference count of a mount point. It also delays unmounting by sleeping on mp if the MNTK_UNMOUNT flag is set in mp->mnt_kern_flag and the MBF_NOWAIT flag is not set. Its arguments are: mp The mount point to busy. flags Flags controlling how vfs_busy() should act. MBF_NOWAIT do not sleep if MNTK_UNMOUNT is set. MBF_MNTLSTLOCK drop the mountlist_mtx in the critical path.RETURN VALUESA 0 value is returned on success. If the mount point is being unmounted and MBF_NOWAIT flag is specified ENOENT will be returned.ERRORS[ENOENT] The mount point is being unmounted (MNTK_UNMOUNT is set).SEE ALSOvfs_unbusy(9)AUTHORSThis manual page was written by Chad David <davidc@acns.ab.ca>.BSDFebruary 11, 2013 BSD
Related Man Pages |
---|
vfs_getnewfsid(9) - netbsd |
vfs_mount(9) - debian |
vfs_export_lookup(9) - netbsd |
vfs_getopsbyname(9) - netbsd |
vfs_mountalloc(9) - netbsd |
Similar Topics in the Unix Linux Community |
---|
The Whole Story on #! /usr/bin/ksh |
Is UNIX an open source OS ? |
A simple UNIXtime component in Vue.js |
UNIX Environment Setup - (Just starting!) |
Controlling user input |