Query: syscall_module
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
SYSCALL_MODULE(9) BSD Kernel Developer's Manual SYSCALL_MODULE(9)NAMESYSCALL_MODULE -- syscall kernel module declaration macroSYNOPSIS#include <sys/param.h> #include <sys/kernel.h> #include <sys/proc.h> #include <sys/module.h> #include <sys/sysent.h> SYSCALL_MODULE(name, int *offset, struct sysent *new_sysent, modeventhand_t evh, void *arg);DESCRIPTIONThe SYSCALL_MODULE() macro declares a new syscall. SYSCALL_MODULE() expands into a kernel module declaration with name 'sys/name'. The rest of the arguments expected by this macro are: offset A pointer to an int which saves the offset in struct sysent where the syscall is allocated. new_sysent is a pointer to a structure that specifies the function implementing the syscall and the number of arguments this function needs (see <sys/sysent.h>). evh A pointer to the kernel module event handler function with the argument arg. Please refer to module(9) for more information. arg The argument passed to the callback functions of the evh event handler when it is called.EXAMPLESA minimal example for a syscall module can be found in /usr/share/examples/kld/syscall/module/syscall.c.SEE ALSOmodule(9) /usr/share/examples/kld/syscall/module/syscall.cAUTHORSThis manual page was written by Alexander Langer <alex@FreeBSD.org>.BSDJanuary 24, 2015 BSD
Related Man Pages |
---|
dev_module(9) - debian |
multi_driver_module(9) - debian |
syscall(3ucb) - sunos |
syscall(3ucb) - php |
syscall(3ucb) - hpux |
Similar Topics in the Unix Linux Community |
---|
Unix File Permissions |
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick |
Scripts without shebang |
Is UNIX an open source OS ? |