freebsd man page for pmap_protect

Query: pmap_protect

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMAP_PROTECT(9) 					   BSD Kernel Developer's Manual					   PMAP_PROTECT(9)

NAME
pmap_protect -- set physical page protection
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> void pmap_protect(pmap_t pmap, vm_offset_t sva, vm_offset_t eva, vm_prot_t prot);
DESCRIPTION
The pmap_protect() function sets the physical page permissions to prot for all physical pages in the physical map pmap in the virtual address range between sva and eva.
SEE ALSO
pmap(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 18, 2014 BSD
Related Man Pages
vm_fault_prefault(9) - freebsd
vm_fault_prefault(9) - debian
pmap(9) - freebsd
pmap_object_init_pt(9) - freebsd
vm_map_protect(9) - linux
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
Scripts without shebang
Memory Leaks
A simple UNIXtime component in Vue.js
Valid separator in time and date format