Query: pmap_object_init_pt
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
PMAP_OBJECT_INIT_PT(9) BSD Kernel Developer's Manual PMAP_OBJECT_INIT_PT(9)NAMEpmap_object_init_pt -- initialize page tables for a VM objectSYNOPSIS#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> void pmap_object_init_pt(pmap_t pmap, vm_offset_t addr, vm_object_t object, vm_pindex_t pindex, vm_size_t size, int limit);DESCRIPTIONThe pmap_object_init_pt() function preloads the page table entries into the specified physical map pmap, for the given object at the virtual address addr, for size bytes, beginning at the page index pindex within the object. The map bits limit are heeded when creating the mapping.IMPLEMENTATION NOTESThis function is not strictly required by an architecture's pmap(9) implementation, but it does provide performance benefits if implemented. It is intended to eliminate the blast of soft faults on process startup, and immediately following a call to mmap(2).SEE ALSOpmap(9), vm_map(9)AUTHORSThis manual page was written by Bruce M Simpson <bms@spc.org>.BSDJuly 21, 2003 BSD
Related Man Pages |
---|
pmap_extract(9) - freebsd |
vm_fault_prefault(9) - debian |
vm_map_lookup(9) - debian |
vm_page_remove(9) - debian |
vm_page_remove(9) - freebsd |
Similar Topics in the Unix Linux Community |
---|
script to loop all process ids and take pmap |