Query: pmap_mincore
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
PMAP_MINCORE(9) BSD Kernel Developer's Manual PMAP_MINCORE(9)NAMEpmap_mincore -- determine if a virtual address is resident in physical memorySYNOPSIS#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> int pmap_mincore(pmap_t pmap, vm_offset_t addr);DESCRIPTIONThe pmap_mincore() function determines if the page at the virtual address addr in the physical map pmap is resident in physical memory. It is the machine-dependent interface used by the mincore(2) system call.RETURN VALUESIf the page is resident in physical memory, a mask of flags is returned, whose meaning is documented in mincore(2); otherwise, 0 is returned. The pmap must exist and addr must be mapped into the pmap. If any error occurs, the machine-dependent implementation should return 0.SEE ALSOmincore(2), pmap(9)AUTHORSThis manual page was written by Bruce M Simpson <bms@spc.org>.BSDJuly 21, 2003 BSD
Related Man Pages |
---|
mincore(2) - opensolaris |
vm_fault_prefault(9) - freebsd |
mincore(2) - sunos |
pmap(9) - freebsd |
mincore(2) - freebsd |
Similar Topics in the Unix Linux Community |
---|
Scripts without shebang |
Reason for no directory creation date |
Valid separator in time and date format |
UNIX Environment Setup - (Just starting!) |
Controlling user input |