freebsd man page for device_quiet

Query: device_quiet

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVICE_QUIET(9) 					   BSD Kernel Developer's Manual					   DEVICE_QUIET(9)

NAME
device_quiet, device_verbose, device_is_quiet -- manipulate device quiet flag
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> void device_quiet(device_t dev); void device_verbose(device_t dev); int device_is_quiet(device_t dev);
DESCRIPTION
Each device has a quiet flag associated with it. A device is verbose by default when it is created but may be quieted to prevent the device identification string to be printed during probe. To quiet a device, call device_quiet(), to re-enable to probe message (to make the message appear again, for example after a device_detach(9)) call device_verbose(). To test to see if a device is quieted, call device_is_quiet().
SEE ALSO
device(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
June 21, 1999 BSD
Related Man Pages
device_is_alive(9) - debian
device_busy(9) - freebsd
device_is_attached(9) - freebsd
device_get_state(9) - hpux
device_get_state(9) - osx
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Reason for no directory creation date
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?