freebsd man page for device_printf

Query: device_printf

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVICE_PRINTF(9)					   BSD Kernel Developer's Manual					  DEVICE_PRINTF(9)

NAME
device_printf -- formatted output conversion
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int device_printf(device_t dev, const char *fmt, ...);
DESCRIPTION
The device_printf() function is a convenience interface to the printf(9) function. It outputs the name of the dev device, followed by a colon and a space, and then what printf(9) would print if you passed fmt and the remaining arguments to it.
RETURN VALUES
The device_printf() function returns the number of characters displayed.
SEE ALSO
printf(3), printf(9)
BSD
April 21, 2003 BSD
Related Man Pages
aprint_normal_ifnet(9) - netbsd
ttyprintf(9) - netbsd
aprint_error_dev(9) - netbsd
aprint_error_ifnet(9) - netbsd
bus_describe_intr(9) - freebsd
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
Memory Leaks
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?
Controlling user input